P8 z68-V/gen3 memory issue?

Just helped my friend assemble his new build, and it won't POST.

The memory light stays on. Hit the button a couple times to go though the memory test, the problem still exists.

Here's the DIMM's we are trying to use

G.SKILL Ripjaws X Series 16GB (4 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Low Voltage Desktop Memory Model F3-12800CL9Q-16GBXM

Anyone else using this Ram on this Mobo?

It's not on the qualified vendors list.

I pushing to return the RAM and exchange it for something that is on the qualified vendors list. Any other suggestions?
6 answers Last reply
More about gen3 memory issue
  1. i have asus z77 saber same mb with a 4 by 4g kit 16gbsr if i installed more then two dimms the mb would not post. i would start with one dimm. if it posts i would then flash the bios with the four flash files and after the last one clear the cmos. then put the working dimm in each slot to test the mb if it posts i would then add one more..if it posts with two dimms add the third if it locks up it the ram. if it wont post with one dimm check under the cpu for bent pins or try another stick of ram. (check that the dimm voltage is 1.5v).
  2. I've tried every different possible combination with the DIMMS. The memory light stays on.

    I pretty sure there's no pins bent, it's an Intel I7 processor so there isn't any pins to bend. I was super careful to align the chip correctly, and with it keyed there's not much chance of error, unless your in a hurry or working in an area that isn't well lit.

    Thanks for the reply though. I think I'll go back and try to get it to POST again by trying every possible combination one more time. Maybe I'll get lucky and not have to ship back theses DIMMs.
  3. FWIW I think you can get this problem if those two TPU and EPU switches aren't selected right. Don't mean to tell you the obvious but I have seen that complaint, I think ...
  4. Not the TPU and EPU switch. But thanks for the suggestion. We're sending back the DIMMs, hoping that's the problem.
  5. Does it work with just 2 sticks?

    I have 2x4gb of G.SKILL Ripjaws X 8GB F3-12800CL9D-8GBXL
    on an ASUS p8z68-v (not gen3) and it works fine from the start. Only 2 sticks and it has an L not an M.


    No. FWIW I did have to wipe them off. It's all clean, right? Sorry about the absurdly low-tech suggestions. Spray some electronics cleaner. [?]


    BTW. So you were able to fit 4 sticks under the CPU cooler! Which cooler are you using with that thing? Me = 212evo.
  6. just got a text message with an image of the bios setup utility. I guess the DIMMS weren't inserted all the way. ha!

    There's just a fine line between too much pressure and not enough. Honest mistake that shows a bit of inexperience.
Ask a new question

Read More

Asus Memory New Build Motherboards