Sign in with
Sign up | Sign in
Your question

ASUS Sabertooth X58 hanging on boot

Last response: in Motherboards
Share
June 23, 2012 12:27:08 AM

System is built as follows:

ASUS Sabertooth X58 motherboard
Core i7-950 CPU
3x4GB Mushkin Enhanced Silverline PC3-12800 memory, triple channel, slots a1 b1 c1
XFX HD6870 video card
Antec p182 case, Antec Neo Eco 620w PSU

I also have a 90GB SSD, 1TB Seagate HDD, DVD burner, card reader, but those aren't even in yet.

From a dead cold boot it hung at the "initializing USB devices..." after telling me it was AMI BIOS and the CPU info.

A reboot gets me no messages, and hangs on the Sabertooth X58 splash screen unresponsive to keyboard input. The keyboard doesn't seem to work except for a split second, the numlock capslock and scroll lock lights will blink. This gives me the same result with four different keyboards, three USB ones and one PS/2.

I have reset the CMOS from the jumper and it will repeat the cold boot result and any further boots get the splash screen.

I have been at this for an hour, and have made zero progress. Any ideas?

Posting this from a dead BlackBerry PlayBook plugged into the wall...
June 23, 2012 7:29:05 PM

Memory is Mushkin 999002 and it is NOT on the list (published September 2010, mind you) of approved memory chips. The thing is, NOTHING creating 12GB of memory from 3 sticks is shown to be supported.

Is there a NEWER list that shows ALL compatibility, from higher density modern memory, instead of this 6x1GB and 3x2GB garbage in the official documentation? Not a lot of these in this list are currently available!

http://www.asus.com/Motherboards/Intel_Socket_1366/SABE...

I just looked again to see what memory is in my wife's computer, it's not the Corsair XMS I thought it was, it's Kingston HyperX, shown here:

http://www.amazon.com/gp/product/B002IO2UM2/ref=oh_deta...

So this is like, the ONLY 3x4GB kit on the list, is this what I need to order for it to actually work?

I did also try to remove all but one memory stick and run it (with the Mushkin) and it did the same thing. It doesn't SEEM to be hanging on memory. I even pushed the MemOK button and all it did was reboot back to that splash screen, I found a picture of it, looks like this. I let it sit for THREE HOURS on this screen and it did nothing but let the fans spin (two on the CPU cooler, the two stock fans on the case, the power supply internal fan, the fan in the video card, the fan blowing on the power supply, and the fan blowing on the upper drive cage) and the green light stayed steady on the motherboard.

I also tried swapping for other known good video cards (also HD6870, and I tried my old HD5770) and even tried the Kingston memory from my wife's computer. It's back in this machine now and works fine. It works fine in her computer, just not in mine. I even swapped power supplies (to her Corsair TX850) and same result.

I'm beginning to think the motherboard is no good, which is NOT good because it's been sitting in the box since we bought it a year and a half ago from Amazon. I'm not sure it can be returned now.
m
0
l
July 3, 2012 5:00:57 AM

I can't select a best answer from myself, but mods, you can feel free to mark this closed and solved. Replaced the Sabertooth with the MSI Pro-E X58 board (used from eBay, because I'm crazy and don't see the point in buying a new 5 year old board). Good to go. Still need to repair the front USB ports on my case which are shorted but I can live without as my card reader has a couple.
m
0
l
!