Sign in with
Sign up | Sign in
Your question

New Asus Sabertooth x79 won't power up

Last response: in Motherboards
Share
June 23, 2012 1:18:17 AM

I just finished building my new rig:

Asus Sabertooth x79
Intel i7-3930k
Corsair Vengeance 4x4gb
Corsair TX850 Watt
Thermaltake Frio Heatsink
Geforce GTX 260
Antec 300 Case

The PSU, GPU, and case are from my old machine, so I know they work.

When I hit the power switch, the mobo fans twitch like is about to start, but then nothing happens.
I've followed the troubleshooting list:
http://www.tomshardware.com/forum/261145-31-perform-ste...

I've tried a different PSU and Case PWR-switch from the family computer, Tried a new cmos battery, applied thermal paste neatly and correctly.

It's currently in a breadboard setup. I wish the Sabertooth had an on board power button like my old Gigabyte x58-UD5

Any ideas would be greatly appreciated.
June 23, 2012 4:03:57 AM

Phew *Solved*

I was pacing around trying to think what else it could be, when i felt something under my foot (yes, i work barefoot). It was a jumper bracket. Turns out it was for the cmos jumper. I looked up where to put it, and voila! it powers up! I guess it slipped off at some point.

Crazy how one little thing can stop the whole machine.

Thanks for the help :p 
m
0
l
Related resources
!