Sign in with
Sign up | Sign in
Your question

Install asus p8z77-v motherboard wifi wireless module

Last response: in Motherboards
Share
June 23, 2012 2:38:35 PM

Hello, just installed ASUS motherboard p8z77-v. Everything is running fine until I installed the wireless module on the motherboard (wifi go! Card) my power button is instantly 'dead' nothing happens until I remove the module from the mother board then I can switch on my computer again. Help is appreciated. I updated until the latest bios etc.
a b V Motherboard
June 23, 2012 2:45:10 PM

Hello,

Get a hold of ASUS if your wifi module is causing your computer to not boot. Can probably get an RMA for it.

- Are you sure you plugged it in properly?

- Is it flush with the slot (not at an angle)?
June 23, 2012 9:13:49 PM

Chainzsaw said:
Hello,

Get a hold of ASUS if your wifi module is causing your computer to not boot. Can probably get an RMA for it.

- Are you sure you plugged it in properly?

- Is it flush with the slot (not at an angle)?


Yes I plugged it in properly. Tried it several times. Nothing happens until I remove it again
Related resources
July 1, 2012 10:22:17 PM

I got a new motherboard. I installed the WIFI Go card and now my computer will switch on but I cannot install the WIFI Go software from the DVD or from the one I downloaded from the ASUS website.
a b V Motherboard
July 3, 2012 2:35:19 PM

Do you receive an error message when trying to install it? If so what is it?

What OS are you trying to install it on? Windows 7 32/64bit?

What does it show as in your device manager? Is there a yellow exclamation there? If so what does it say?
!