Sign in with
Sign up | Sign in
Your question

M5A99x EVO No Post after bios upgrade

Last response: in Motherboards
Share
June 23, 2012 3:42:36 PM

I just got my M5A99x yesterday bundled with a fx-8120, and everything was working fine. However i thought i might as well update the Bios, so i decided to use the updater software on the cd. However the second i clicked update my screen froze, i waited for 20 secs with no avail so i forced shut down. When i rebooted it was in recovery and asked me to put in the support disk i did and nothing happened for 20 mins so i forced shut down....the next boot no post and beep codes: 2 long followed by 6 short beeps which loop. Ive tried resetting the cmos by the jumpers and the same result and then i tried simply putting the cd in and turning on and nothing, same with a usb stick. What should i do next its in warranty (i bought it from pc world UK online last weekend). order a new bios chip,send motherboard back to pc world or Asus? or try a method at home? thanks in advance and i know now "if its not broken don't try and fix it"
July 12, 2012 3:31:49 AM

did you fix problem i have same mobo but i updated my bios from usb drive and it worked i have fx 6100 and just see if you fixed :) 
a b V Motherboard
July 12, 2012 5:59:02 AM

You only got the mobo yesterday and you update the bios? I've never updated my bios and never have the problems that users have nowadays. Even my old windows XP sp3 Pc has a bios over 10 years old. lol

Well, actually, I did do a bios update on an olde Pentium 2 Pc about 10 years ago and wrecked it (vowed never to do it again).

All you can do is return it and say it never worked when you got it and hope they replace it.



!