Sign in with
Sign up | Sign in
Your question

Multiple ASRock Extreme4 Z77 problems.

Last response: in Motherboards
Share
June 23, 2012 9:00:07 PM

About a month and a half ago my old rig broke so I bought a new mobo and cpu. The mobo I bought was an ASRock but it wasn't compatiable with the Ivy CPU I have (an i-5 3550). So I RMAed it though newegg and got a Extreme4 Z77.
When I connected everything to my rig my Sapphire Radeon HD 6870 wasn't being detected my my motherboard at all. I thought I was fried from being left in a box for a few weeks so I RMAed it though Sapphire and got a replacement. Now I have the new replacement card and it is detected most of the time by my motherboard, but whenever I try to switch the BIOS settings from onboard graphics to the PCI-E I get a black screen and no output to my monitors. I've tried everything. I've updated my BIOS, installed drivers, cleared my CMOS, even prayed and nothing seems to be working.

I'm also getting random BSOD crashes that are related to a change in hardware. These may or may not be related to my motherboard, but they're annoying.

And last but not least, my system won't sleep. I've messed around with the BIOS settings and nothings seems to work. The system monitor also isn't working. The temperatures that are being displayed aren't accurate (-.5C) and the clock speeds are wrong.

The motherboard is out of the 30 day period of return and if I could return it I would and get another motherboard, probably not an ASRock, but I can't, so I'm wondering if I RMAed back to ASRock would I run into these issues? Is my motherboard broken or is something else wrong? Also is it possible that I have some compatibility issues between my motherboard and my Sapphire Radeon HD 6870?

I have created a ticket and emailed ASRock support but it's a Satuday and they're closed. I really just want to be able to play some video games again since it's been a month and a half and I haven't been able to game with my rig.
Any help would be appreciated.
June 25, 2012 11:29:47 PM

I also have gotten the 00 Dr. Debug code which I've seen around and it must mean that the board is bad. I'm RMAing my board and I'm going to see if that solves the problem.
m
0
l
October 18, 2012 1:36:14 AM

I have this exact problem with the same motherboard and the same CPU my gpu is a nvidia 560 ti , have you managed to solve it?
m
0
l
October 18, 2012 1:42:28 AM

I RMA'd the board because the Dr. Debug was a bad thing but the GPU still didn't work. I got sick dealing with it so I bought a 7850 and it works now. I dropped $260 on it and it's worth no more than $200 but at least it works with my rig.

Good luck.
m
0
l
!