Sign in with
Sign up | Sign in
Your question

Sabertooth 990FX Issues.

Last response: in Motherboards
Share
June 23, 2012 11:53:42 PM

My Sabertooth 990FX will not boot, no screen at all. Black, dead to the world on video. CTRL + ALT + DEL will restart system while it is running and without the video. I am give a 'system' check short beep to confirm the system is working however the 'boot device' LED stays on. It was working perfectly fine and shut down correctly on 6/21/2012.
I'm currently also looking for a replacement in this forum:
http://www.tomshardware.com/forum/314906-30-need-replacement-help#t2107947

Until then I would like to boot my system at least.
  1. I have tried to Reset CMOS correctly.
  2. I have Windows 7 Ultimate.
  3. HDD Works 100%.
  4. Sometimes booted after this problem after trying all steps repeatedly.
  5. All components except MoBo work.
  6. Monitor works.
  7. HDMI output wont work either.
  8. Followed mem test directions.
  9. Replaced battery.
  10. Bios was the latest, Version 1208, 2012


Here is what I have currently:

ASUS Sabertooth 990FX AM3+ AMD 990FX SATA 6Gb/s USB 3.0 ATX AMD Motherboard with UEFI BIOS
http://www.newegg.com/Product/Product.aspx?Item=N82E16813131736

CORSAIR Professional Series HX1050 1050W ATX12V / EPS12V SLI Ready CrossFire Ready 80 PLUS SILVER Certified Semi ...
http://www.newegg.com/Product/Product.aspx?Item=N82E16817139034

CORSAIR Vengeance 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1866 Desktop Memory Model CML8GX3M2A1866C9R
http://www.newegg.com/Product/Product.aspx?Item=N82E16820233240

LITE-ON Black Internal 12x BD Combo SATA Model iHES212-08 LightScribe Support
http://www.newegg.com/Product/Product.aspx?Item=N82E16827106451

AMD FX-8120 Zambezi 3.1GHz Socket AM3+ 125W Eight-Core Desktop Processor FD8120FRGUBOX
http://www.newegg.com/Product/Product.aspx?Item=N82E16819103961

XFX Double D HD-695X-CDFC Radeon HD 6950 2GB 256-bit GDDR5 PCI Express 2.1 x16 HDCP Ready CrossFireX Support Video
http://www.newegg.com/Product/Product.aspx?Item=N82E16814150549

Western Digital Caviar Black WD1502FAEX 1.5TB 7200 RPM 64MB Cache SATA 6.0Gb/s 3.5" Internal Hard Drive -Bare Drive
http://www.newegg.com/Product/Product.aspx?Item=N82E16822236117

Microsoft SideWinder X6 Black Keyboard Win USB English
http://www.newegg.com/Product/Product.aspx?Item=N82E16823109063

Razer Mamba 2010
a b V Motherboard
June 24, 2012 12:38:45 AM

So it's running, but no video and boot device led is on?


What do you mean by it "sometimes booted"? With video?
June 24, 2012 1:12:13 AM

It would sometimes boot after trying all steps for correcting the boot problem, replugging in all devices and trying combinations of USB to hub possible.

It's hard to describe, imagine trying all steps while plugging in keyboard, mice, and dvi/hdmi in all combinations though.
Related resources
a c 462 V Motherboard
June 24, 2012 1:23:10 AM

it could be that your pulling to much power from the usb ports or one of your usb device is the issue. i would try another mouse and keyboard...if you still get the reg led for boot device. unplug the dvd then hard drive to see if one of them has gone bad.
June 24, 2012 2:02:51 AM

Both the DvD and Hard Drive work fine, the USB devices seemed like the problem, however they do not work with a USB hub I have, and the HUB method worked before, last week.
June 24, 2012 10:52:35 AM

Check your graphics card, give it a clean. I had this problem once it turned out to be dust on the graphics cards board under the heatsink. Once cleaned it worked again for me.
a b V Motherboard
June 24, 2012 11:32:58 AM

electricfirebolt said:
Check your graphics card, give it a clean. I had this problem once it turned out to be dust on the graphics cards board under the heatsink. Once cleaned it worked again for me.


LOL


Anyways, when you say sometimes it boots, do you mean you actually get video? You seem to not be answering the question.
June 25, 2012 5:51:49 PM

How does dust get in there!? The video worked flawlessly for months though.

Any one else have an idea?
I tried the CMOS method.
BIOS didt not clear at all, I think the BIOS chip is fried, has anyone ran int othis problem before at all?

I think the ACHI setting caused this, fair warning.
a c 462 V Motherboard
June 26, 2012 12:24:38 AM

as the boot led is on red. i would unplug the dvd first and see if it post then the hard drive. i would also bare bone the ram to one dimm. also i would try and run on the onboard ram to see if the main video card went bad or there a power issue with the ps.
June 26, 2012 4:43:47 AM

Viper11025,

Have you read this thread.

http://www.tomshardware.com/forum/286558-30-boot-clear-...

I had a problem with the Asus 990FX motherboard not booting unless I clear the CMOS. I found a work around if I connect the computer case power cables to the motherboard and pressed the power button on the case, that worked.

Kenan
!