Sign in with
Sign up | Sign in
Your question

Radeo 5970 GPU1 and GPU2 usage jumps to 99% ??

Last response: in Graphics & Displays
Share
April 23, 2011 4:25:52 AM

Hey everyone

I've been fishing around here to see if I can resolve my issue that I'm having with my Radeon 5970. I can't seem to find anything so I thought I'd lay it out after having done some investigations myself (thanks to some posts I found in the forums).

Firstly, this is my system:

- i7 950 @ 3.07GHz
- Radeon 5970
- G.SKILL F3-12800CL8T-6GBRM Ripjaws 6GB 3X2GB DDR3-1600 CL8-8-8-24 240PIN Triple Channel i7 Memory
- Corsair TX750 supply
- dual Dell monitors (running at 1280X1024, 60Hz, 32bits)
- Windows 7 64-bit

Now before I describe the issue, I should mention that I first noticed something was amiss when my screensaver was running, and I moved the mouse to bring back the logon screen. It took *forever* to bring up the logon screen (when it usually happened instantaneously). After I entered my password, it took forever to switch from logon screen to the desktop. I noticed also that the Catalyst Control Center was indicating that the Activity on the card was at 99%. That seemed odd, but I wasn't sure what that was measuring, so I hunted around for info. In the meantime I called AMD and reinstalled the drivers, twice. By their recommendation I used DriverSweeper the second time to make sure all the old drivers were cleaned off. Interestingly, at a certain point during the uninstall process (i.e., after I ran the Catalyst Install Manager and told it to uninstall everything, but before it finished), the issue was resolved. I suspected it was due to a driver issue that was resolved when the driver was uninstalled. Every time, after I uninstalled, the Device Manager would show ATI Radeon 5970 drivers loaded, that I assumed were generic windows drivers...they didn't allow me to use any direct3d stuff (e.g., I couldn't use the screensavers for windows that use direct3d). The only time I noticed the 'issue' was when I used the ATI catalyst (newest) drivers.

Finally, I've recently done some additional looking into this using msi Afterburner and GPU-Z. According to MSI Afterburner, the GPU usage (either GPU1 or GPU2) jumps to 99% at some point and the other one follows shortly afterwards (seems less than 10 minutes later). During one instance the GPU2 jumped first, and I brought up the logon screen with no issues (by hitting CTRL ALT DEL). However, once GPU1 jumps to 99%, I can't switch to the logon screen without going through about a 30s wait to bring it up and a 30s wait to return to the desktop.

A few other things:
- One time when I initiated the 'issue', while monitoring with msiAfterburner, I had GPU2 jump up before GPU1. The other time, it was the other way around.
- It happens whether or not I'm working on the computer (i.e., sometimes it happens in the middle of my work, other times while the screen saver is on and I'm away)
- I used to get messages occasionally from Windows that my graphics device had crashed and recovered. I don't believe I've had them since this issue has started.
- When I was paying closer attention another time, GPU1 jumped before GPU2. When GPU1 jumped, the core clock and memory clock stayed at 400 and 900 respectively, but when GPU2 jumped the core clock and memory clock jumped permanently from 157 and 300 to 725 and 1000 respectively.
- Not surprisingly, I notice the 'issue' (very slow logon screen load and unload) also when I am installing or running programs and Windows brings up the User Account Control dialog (the one that asks if you want to allow the program to make changes). The issue seems to be the transition between the desktop and whatever 'mode' it is in which the logon screen and the User Account Control dialog runs - clearly having GPUs running at 100% makes this transition take forever.

Any advice or help would be great. I saw some mention of adjusting the voltage levels, but I can't seem to do it in Afterburner (won't let me move the slider, nor does it give me a measurement for it). For the record, I looked at the voltage levels in GPU-Z. Turns out that I can select one GPU or the other in GPU-Z, but strangely, there was one extra voltage measurement for one GPU versus the other. Anyway they were:

GPU1: VDDC and VDDCI: 1V and 1.1V respectively
GPU2: VDDC: 0.95V

I also noticed that my fan speed (as percentage) in GPU-Z doesn't match the fan speed reported by msiAfterburner, and that it doesn't change at all when I can clearly hear my fan changing and when the fan rpms does change.

Thanks for any help
April 23, 2011 4:56:20 AM

Possible update: Some further playing may have linked this issue to Firefox and/or Adobe Flash. I've been doing the same things I was doing with Firefox (except now using IE, both 32 and 64 bit), and I've seen no issues so far. If anyone else has noticed issues with Firefox and/or Flash and the Radeon drivers, and can let me know, I'd be most grateful. In the meantime I'm going to reinstall Firefox. This might have been no more than a Firefox bug. Fingers crossed.
m
0
l
April 23, 2011 5:32:17 AM

Interesting. I had issues with IE 8 and flash. It seemed that when I ran a flash video, it would lock my clock speeds at some place between idle and normal 3D speeds and they wouldn't change until I closed the page. Firefox fixed the issue for me.
m
0
l
Related resources
Can't find your answer ? Ask !
April 23, 2011 2:05:51 PM

UPPERDATE: I did isolate the problem to Firefox 4 (only) and/or Adobe and/or flaky drivers. It seems that this is not unheard of for some people, and it involves the Firefox 4 GPU hardware acceleration mode. Probably Flash is the trigger that causes Firefox to use hardware acceleration, which is why it seemed to show up intermittently at first. So far there is no fix for either Firefox or the drivers, so the only options are to downgrade to Firefox 3.6, or switch browsers, or disable hardware acceleration.
m
0
l
April 23, 2011 4:47:59 PM

bystander said:
Interesting. I had issues with IE 8 and flash. It seemed that when I ran a flash video, it would lock my clock speeds at some place between idle and normal 3D speeds and they wouldn't change until I closed the page. Firefox fixed the issue for me.

this was only a flash issue afaik, had it happen on firefox. flash version 10.2.something fixed this, it was on the release notes.
m
0
l
!