Sign in with
Sign up | Sign in
Your question

2 NIC's on server with different subnet - DNS problem

Last response: in Networking
Share
September 12, 2010 9:18:44 AM

Hello, i have problem with 2 nic's on one server (file server). This server is virtual machine (win2k3) and the reason for 2 nic's is backup on different locations. In each locations is different subnet: 10.213.1.x and 10.213.101.x;
Both nic's are active (not disabled) but only one is still connected (with cable) to network, depends on which location is server active.
The problem is following: I have two records in DNS with same server name and different ip address. I need to automaticaly set the correct IP adress in DNS record depending where (on which location) the server is actually active. More details: Each nic have manualy set the ip address, gateway and DNS. Thanks for help.
September 12, 2010 10:53:11 AM

PistikSC said:
Hello, i have problem with 2 nic's on one server (file server). This server is virtual machine (win2k3) and the reason for 2 nic's is backup on different locations. In each locations is different subnet: 10.213.1.x and 10.213.101.x;
Both nic's are active (not disabled) but only one is still connected (with cable) to network, depends on which location is server active.
The problem is following: I have two records in DNS with same server name and different ip address. I need to automaticaly set the correct IP adress in DNS record depending where (on which location) the server is actually active. More details: Each nic have manualy set the ip address, gateway and DNS. Thanks for help.


I could have over-simplified this but it seems to me it may help if the server had each of its connections named differently. Even if it doesn't fix the problem, it will ease confusion if nothing else.


September 13, 2010 5:36:28 AM

Saga Lout said:
I could have over-simplified this but it seems to me it may help if the server had each of its connections named differently. Even if it doesn't fix the problem, it will ease confusion if nothing else.



Hi, thanks for help, but this not solve the problem because the connections are named differently by default.
!