P8Z77v Pro - Asmedia Internal SATA drive shown in Safetly Remove list

I have a P8Z77v Pro running Win 7 Pro 64bit to which I've fitted a HDD to the Asmedia SATA port.

I've installed the Asmedia drivers provided and everything works fine with the exception that the drive now appears as a removable drive and is included on the Safetly Remove Hardware list. What do I need to tweak to remove the drive from the list - I can't see any bios settings associated with the ports that can do this so does anybody know of any registry tweaks?
6 answers Last reply
More about p8z77v asmedia internal sata drive shown safetly remove list
  1. My Seagate 500gb hard drive shows up there too and I just ignore it.

    Is there any specific reason you need it gone? Do you accidentally click it?
  2. We (the family) use a lot of USB devices (MP3 players, Memory Sticks) and it just adds a bit of confusion. Would like to get rid of it if pos.
  3. Per this thread


    do the following:

    - edit - You will have to change the video card related stuff to hard drive related stuff, but it should still work.

    The solution provided below is credited to (http://www.paralint.com/blog/2008/11/13/stop-internal-drive-showing-up-in-safely-remove-hardware/)Guillaume at Parallel Interface (http://www.paralint.com/blog/2008/11/13/stop-internal-drive-showing-up-in-safely-remove-hardware/). This method will work for other permanent devices in your system that you do not want listed in your Remove Hardware Safely list.

    How it’s done:

    • Must Login as Administrator
    • Find Device DWORD Value in Regedit
    • Create command line in Schedule Task as SYSTEM
    • Works for various system devices connected, and modification is easily reversible by simply deleting the Schedule Task created


    1. Locate Your Device(s) in Regedit:


    · This will bring up a list of available hardware connections. For SATA DVD-rom drives, and hard drives look under IDE. For Video Cards look in PCI.

    2. Once you find your device, expand it and click on the first key folder under it (looks something like 4&15e311de&0&0.1.0).
    · The Capability value in this key folder should be greater than 0.
    · Take a note of the Capability number (my dvd-rom drive is set at 6)


    3. Right-click the key folder and select Copy Key Name.

    4. Open Task Scheduler > Create Task > and set the following parameters:

    · Change User or Group (Under Security Options) and set it to SYSTEM
    · Configure for: Chose your platform
    · Triggers Tab > New > Begin the Task > At Startup
    · Actions Tab > New
    - Program/script: reg.exe
    - Add arguments: add "paste your copied key name here" /v Capabilities /t REG_DWORD /d Your Capability Number minus 4 here /f

    Example: add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\I DE\CdRomOptiarc_DVD_RW_AD-7240S_________________1.01____\4&15e311de&0&0.1.0" /v Capabilities /t REG_DWORD /d 2 /f

    5. Right-click the new Scheduled Task and click Run. You should see the results immediately. Logoff/Logon and the safely remove your hardware icon will be gone if there are no removable devices connected.

    ·To undo the changes you made above, simply remove it from your schedule task and reboot. Without the Schedule Task, the system will automatically restore the registry values back to their original after a reboot.

    I have tested everything I wrote above, and it is working great. Enjoy!
  4. Many thanks Raiddinn. I could not get it work exactly as you mentioned but I have got it working. I have two drives connected to the ASMEDIA interfaces and now they've both gone from the Safely Remove list!

    The problem I had is that the using the programme reg.exe didn't seem to work - and no clues as to why not. I'm convinced I typed everthing correctly. What I have done, however, is to use regedit.exe and point to a .reg file that contains the altered registry entries for both drives. The contents of the .reg file are:

    Windows Registry Editor Version 5.00



    I called this file RemoveAsmediaDrives.reg and put it in the c:\windows folder and then used the following parameter line in the Task Scheduler:

    /s C:\Windows\RemoveAsmediaDrives.reg

    Works a treat.
  5. There is a bios setting on the P8Z77v Pro for this.

    Bios- ->Advanced Mode (f7) -->Advanced -->SATA controller

    under each drive is an option "Hot plug" Enable makes drive hot swappable Disable make the drive not hot swappable

  6. Here's the easiest solution: I also have de Asmedia 106x SATA controller on my MSI Z77A-GD80 mobo and
    I had the same problem:

    1) Just got to control panel -> device manager -> IDE ATA/ATAPI Controllers

    2) There you'll see the Asmedia 106x (or other models) Controller: right click -> Properties

    3) In the second tab, Policies, you can uncheck the box 'Enable safely remove disk'... done! :D

    Note: Check your driver version in the third tab. Mine was old: from 22 Jun 2012 but this feature was already supported. Older versions might not support this yet!

    Update: Apparently the latest Asmedia 106x driver does not support this version anymore : http://www.win-raid.com/t303f25-RE-ASMedia-x-SATA-AHCI-drivers.html

    That site actually contains a lot of info on the drivers: http://www.win-raid.com/t29f25-Recommended-AHCI-and-RAID-Drivers.html is a great overview for these kind of drivers!
Ask a new question

Read More

Asus SATA Asmedia Motherboards Hard Drives