Which Mobo? (ASRock, Asus, Gigabyte)

First thing's first. Let me start off by saying I have received two of the ASRock boards and both seem to have been DOA.

With that out of the way, should I try ASRock again? http://www.newegg.com/Product/Product.aspx?Item=N82E16813157271

Or should I try one of these two:

ASUS: http://www.newegg.com/Product/Product.aspx?Item=N82E16813131781

Gigabyte: http://www.newegg.com/Product/Product.aspx?Item=N82E16813128498

Which motherboard is better spec wise? And which motherboard is better company wise?

I'm getting really aggravated with the ASRock boards, but it does look pretty ;D plus it was recommended by someone on these forums. :)
7 answers Last reply
More about which mobo asrock asus gigabyte
  1. I've never had a new board doa in twenty years. It may not work if you're using a new cpu that requires a bios update before it will post; if the ram stick isn't fully seated; if the power supply is old or inadequate for your system load, etc. You need to do some more troubleshooting or get someone to help you before ordering a new board. You may have another issue that is not related to the asrock board.
  2. It's not the power supply. It's not the bios on the motherboard. The problem is either a dead mobo or a dead cpu. No power is getting to the motherboard for it to even beep at me. That's with the psu/cpu/heatsink/mobo attached (also tried with 1 memory stick.)

    And since nothing is powering on (LED or fans) and their are no beeps it leads me to believe that the mobo is the problem and not the cpu (but I could be wrong.)
  3. Some boards don't run with certain power supplies. I would borrow another one if you can or purchase a spare. Have you tried the board on wood or cardboard out of the case (breadboarding)? With this technique, you touch the case pin cluster on the motherboard with a screwdriver and move it around until it fires up. Maybe you just have the power switch lead on the wrong pins.
  4. I was referring to the motherboard LEDs and yes I've tried bread boarding. I've also tried 3 different power supplies.
  5. are you using a sandy bridge processor on these boards? because if its ivy bridge, then theres your problem, the problem lies within the non updated bios.
  6. Yes sandy bridge, i7 2600k. I've already made a couple of posts about this. Please note my original post asked 2 simple questions that just happened to include my rants from my annoyance of that motherboard over the past 2 weeks.
  7. Only other possibility is the cmos jumper is out of position. Check the manual for the correct pins to cover for the "run" position.
Ask a new question

Read More

Motherboards Asus Gigabyte ASrock Product