AMD 11.4 drivers are out!

The OFFICIAL 11.4 drivers are released! This is what caught my eye since I own almost every game on this list.

Quote:
Performance Enhancements
A number of performance enhancements are seen with the AMD Radeon HD 6900 Series and AMD Radeon HD 6800 Series:

* Call of Duty Black Ops – gains of up to 15% with Anti-Aliasing and Anisotropic Filtering on single GPU configurations.
* Battleforge – gains of up to 15% with Anti-Aliasing and Anisotropic Filtering on single and multiple GPU configurations.
* Batman Arkham Asylum – gains of up to 20% with Anti-Aliasing and Anisotropic Filtering on single and multiple GPU configurations.
* Aliens vs. Predator – gains of up to 8% with Anti-Aliasing and Anisotropic Filtering on single and multiple GPU configurations.
* Civilization 5 – gains of up to 15% on single and multiple GPU configurations.
* Far Cry 2 – gains of up to 6% on single and multiple GPU configurations.
* Just Cause 2 – gains of up to 9% on single and multiple GPU configurations.
* Lost Planet 2 – gains of up to 10% on single and multiple GPU configurations.


Download them here: http://sites.amd.com/us/game/downloads/Pages/downloads.aspx
28 answers Last reply
More about drivers
  1. I had MAJOR problems with this driver. I have a 5870 and after install I got blue screened. So I restarted and reinstalled and restarted again without blue screen problems and what do ya know.... it says I don't have a supported card for the installed drivers which isn't true. I tried to reinstall again and then CCC won't even come up and my desktop res is all messed up.

    I rolled back to 11.3 and everything is fine now. Shame since firefox 4 acceleration issues were supposed to be fixed in this new version. Maybe they just forgot to include 5870 support in this pack. A single line of code my bet.

    Anyone one else with a 5870 have the same issues as I?
  2. I'm about to try them on my 4850. If that goes well, I'll see if I can try them on my 5850 (closest thing I have to a 5870).
  3. About to give it a go on my 6850. Hope it goes smoothly.
  4. No problem on my 4850. Seemed to have fixed some issues - and now it is the "AMD Vision Engine Control Center" !!!
  5. Downloaded and will probably install this evening.
  6. lancerzero9 said:
    I had MAJOR problems with this driver. I have a 5870 and after install I got blue screened. So I restarted and reinstalled and restarted again without blue screen problems and what do ya know.... it says I don't have a supported card for the installed drivers which isn't true. I tried to reinstall again and then CCC won't even come up and my desktop res is all messed up.

    I rolled back to 11.3 and everything is fine now. Shame since firefox 4 acceleration issues were supposed to be fixed in this new version. Maybe they just forgot to include 5870 support in this pack. A single line of code my bet.

    Anyone one else with a 5870 have the same issues as I?

    did you uninstall the old drivers first? try running driversweeper following all instructions to remove the old drivers properly. then install 11.4
  7. I just did a normal uninstall on my 5850, and 11.4 installed nicely (with a reboot between and after).
  8. i have a 5870 and it installed fine on my system. with only 1 reboot after it finnished writing the files as per usual. i just install over the top of my old drivers as its recommended for win7 in the springboard series.
    using win7 ultimate 64bit
  9. lancerzero9 said:
    I had MAJOR problems with this driver. I have a 5870 and after install I got blue screened. So I restarted and reinstalled and restarted again without blue screen problems and what do ya know.... it says I don't have a supported card for the installed drivers which isn't true. I tried to reinstall again and then CCC won't even come up and my desktop res is all messed up.

    I rolled back to 11.3 and everything is fine now. Shame since firefox 4 acceleration issues were supposed to be fixed in this new version. Maybe they just forgot to include 5870 support in this pack. A single line of code my bet.

    Anyone one else with a 5870 have the same issues as I?


    Thank god I'm not the only one.

    I actually had a pair of 6870s, but my process was similar to yours -- only I BSOD'ed during the install itself. Then, no matter how I cleared the drivers (via the Catalyst Installer's uninstall feature or Driver Sweeper), the driver would never recognize -- something wrong with the installer, I think, as it didn't ask me to reboot when I installed (11.3's installer did, and the uninstall on 11.4 did). Whenever I did a manual reboot, I would only have the AMD Vision Control Center or whatever it's called in my systray and when I right-clicked the desktop and could change my CPU clocks with it (which I could do with Catalyst anyway), but I had 0 GPU-related options in Vision. I installed 11.3 again and Catalyst was back.

    I'm curious to see what happens if I just install the new driver and leave everything else (Catalyst, profiles, all the other options) intact.
  10. For some reason I can't turn on AA in Civ 5. I don't know if its these drivers or not. Can someone try this with these drivers to see if they have the same problem? Preferably with a Windows 7-64 bit setup.

    First time I played Civ 5 since the 11.1 drivers and I didn't have this problem then. Not worth the hassle of reverting back to 11.3 but still.
  11. This driver has pretty much solved most of my crossfire issues. Still getting a little bit of flickering in Crysis 2 and Mafia 2 but the performance has increased alot and theres no drop in frame rates as with 11.3.
  12. This driver solved my disappearing CCC issue (something that only happens on my XFX).
  13. wannaturnuptheheat said:
    Thank god I'm not the only one.

    I actually had a pair of 6870s, but my process was similar to yours -- only I BSOD'ed during the install itself. Then, no matter how I cleared the drivers (via the Catalyst Installer's uninstall feature or Driver Sweeper), the driver would never recognize -- something wrong with the installer, I think, as it didn't ask me to reboot when I installed (11.3's installer did, and the uninstall on 11.4 did). Whenever I did a manual reboot, I would only have the AMD Vision Control Center or whatever it's called in my systray and when I right-clicked the desktop and could change my CPU clocks with it (which I could do with Catalyst anyway), but I had 0 GPU-related options in Vision. I installed 11.3 again and Catalyst was back.

    I'm curious to see what happens if I just install the new driver and leave everything else (Catalyst, profiles, all the other options) intact.

    maybe there are problem with specific cards, bios's perhaps. would be interesting to see if the cards having issues are from the same manufacturer.
  14. I had issues with my crossfired 5870's with the 11.3 drivers. Never could get them to install properly (black screen that never went back to the desktop - there's a whole other thread about it.) So, I've been using the 11.4 preview drivers since they were available, and they have been the most stable for me so far (11.2 would not even let me activate crossfire). I have yet to install the official 11.4 drivers, but I am hoping it fixes my Dragon Age II crazy texture pop-in problem (textures that should NEVER be where they are.)
  15. I tried again with the 11.4 drivers and still no luck after several different methods. Windows just doesn't see the driver or even ask me to restart after I installed it. The AMD installer program does however see it when I go to uninstall it to roll back.

    11.5 will be out in a month or two anyway. I'm using the Sapphire 5870 btw.
  16. lancerzero9 said:
    I tried again with the 11.4 drivers and still no luck after several different methods. Windows just doesn't see the driver or even ask me to restart after I installed it. The AMD installer program does however see it when I go to uninstall it to roll back.

    11.5 will be out in a month or two anyway. I'm using the Sapphire 5870 btw.


    AMD drivers come out every month and also, do you have your windows update turned off? When it sees a missing driver sometimes it goes online to find a driver and it installs it automatically unless you turn it off. This may be the problem.
  17. Carc369 said:
    AMD drivers come out every month and also, do you have your windows update turned off? When it sees a missing driver sometimes it goes online to find a driver and it installs it automatically unless you turn it off. This may be the problem.


    Lancer's issue is identical with mine. I, oddly enough, had a SAPPHIRE 6870 as my primary GPU... maybe the brand is the problem?

    Anyways, no, what he has is what I had -- the ATI driver simply wasn't there with 11.4. The installer doesn't say "Actions taken require a system reboot", like it does with previous installers, a manual reboot causes Windows to revert to the default generic driver, and a pop-up comes up saying "No AMD driver installed for your AMD device" or something like that. Rolling back to 11.3 and clearing only ATI/AMD drivers (didn't touch Windows drivers/Windows update) fixed the issue, the AMD display driver was detected and all that jazz.

    Sigh, now I kind of want to move my XFX card to the primary PCI-e slot to see if the drivers work, but that's way too much effort for me...
  18. My 4850 (which is XFX and usually buggy) worked fine with 11.4 and my 5850 (which is Sapphire) worked fine, so I don't think it is that simple. If you manually install the drivers (device manager), does it just uninstall them or give errors on reboot?
  19. I have only tried two games so far since moving up to 11.4. Bad Company 2 finally works again in Crossfire for me, with the fps count improving 23-40 fps over single card mode. The other game was NFS Hot Pursuit. I dont really like the game, but I figured I'd try it just to see if they really fixed Crossfire support for it finally. As quoted on their site "Need For Speed Hot Pursuit – resolves negative CrossFire scaling". Well, I'd have to say, umm no, sorry, no dice. Crossfire did improve over the prior driver and profile sets a tad, but it was still clearly in the negative.

    single card 1920x1080
    2011-04-29 02:56:31 - NFS11
    Frames: 2783 - Time: 70651ms - Avg: 39.391 - Min: 33 - Max: 46
    Crossfire 1920x1080
    2011-04-29 03:06:41 - NFS11
    Frames: 2372 - Time: 69897ms - Avg: 33.936 - Min: 28 - Max: 38

    I ran the same race, the very first one in career mode, and did benched the exact same section of that race multiple times. The outcome was basically about the same numbers posted above each time I did so. Clearly Crossfire support for that game is still in the negative, at least for me. This is not a big deal for me though, as I did not like this game, but I can imagine others who do, who are using crossfire, would be upset if they did not get the stated improvement there.
  20. Posts like that ^ are much to common for me even to consider crossfire.
  21. Downloading.
    Hope it fixes the 99% GPU bug or I'm still stuck with 10.10 :(
  22. Carc369 said:
    Posts like that ^ are much to common for me even to consider crossfire.


    Crossfire's a bitch...

    But those moments when it's working perfectly can really make it worthwhile.
  23. Carc369 said:
    Posts like that ^ are much to common for me even to consider crossfire.


    Honestly I cant really blame AMD for Crossfire issues with the newer NFS games. NFS titles have been poorly optimized and plagued with problems since Shift 1. Even Undercover presented some issues, and this applies to both SLI and Crossfire. One of Slightly Mad Studios programmers has been posting in some forum lately about how they have been working with Nvidia and AMD to improve dual card support in Shift 2, let alone single card performance. I think the newest patch was supposed to solve some of the problems, but I dont remember what all the guy posted as far as fixes are concerned. And even if the games were optimized better, I don't find them very fun. Carbon, Most Wanted, and Pro Street were the last best NFS titles for me. I felt a bit ripped off concerning Undercover, Hot Pursuit, and Shift 1 and 2. Even if Split Second is basically arcade style racing, it mops the floor with the latest NFS titles entertainment and excitement wise. That and it looks and runs better (even if lacking dual card support).

    The odd thing about Crossfire for me has been that it typically works on games that I really need it to work on, and any title that really doesn't need the extra horsepower, seems to not be supported, or is, but is a waste and so I run it in single card mode. Games that I enjoy, that I knew I'd need the extra gpu power on, like Metro 2033, DOW 2, Resident Evil 5, Company of Heroes, and Bulletstorm, etc all work fine for me in Crossfire. Considering I got my two HD 5770 cards for $115 and $120 each new back last June, I'd say I have gotten my moneys worth. Granted, that doesn't apply to everyone, but for me, I can't complain really. I got what I wanted. Anyone who paid for the NFS titles though and are having dual card issues, you can aim your blame the development studios just as much as Nvidia and AMD, if not more so, as it is mostly their problem. And you would have every right to bitch too. Nothing worse then plopping down a lot of cash for a decent gaming rig, then spending another 50 bucks on up for a game, and have it look average maxed out as is, and run like crap on good hardware, regardless of single or dual card configs.
  24. I had some problems with the 11.4 betas. Did you guys have trouble enabling crossfire using the 11.4 official release drivers? Every time I checked the crossfire setting, it would just uncheck itself and not engage... Did that fix that issue?
  25. jednx01 said:
    I had some problems with the 11.4 betas. Did you guys have trouble enabling crossfire using the 11.4 official release drivers? Every time I checked the crossfire setting, it would just uncheck itself and not engage... Did that fix that issue?


    I had that issue when I installed 11.3 when I swapped my cards (physically, from one slot to the other). A few reboots got it working again.
  26. I had no Problem with 11.4 , i am using 6870 ! Maybe 11.4 is not for 5000 series !
  27. 11.4 is for all of them. Works great on my 5850 and 4850.
  28. Working on my HD6850 -- no problems.
Ask a new question

Read More

Radeon GPUs Drivers AMD Graphics