BOOT freeze with Segate 2TB USB3 connected

Hi all

I really need help with this

I have a new computer with ASUS P8Z77-V-Deluxe
a new Seagate 2TB USB3 that worked perfectly with my older computer

When it's connected to the new computer, it gets stuck on boot logo
MB Q-Code shows "b2" code. Which is Legacy Option ROM initialization

when i cold start the computer it boots fine.
When I restart the computer it gets stuck.
When I reset, it works fine again.
So every restart it gets stuck.
When I disconnect the drive, I can restart with no problem.

the external seagate is not setup to boot in BIOS.
Please help

thanks

Gil
4 answers Last reply
More about boot freeze segate usb3 connected
  1. Do you have boot from USB enabled in BIOS?
  2. Update bios to latest version.
    http://www.asus.com/Motherboards/Intel_Socket_1155/P8Z77V_DELUXE/#download

    P8Z77-V DELUXE BIOS 1206
    1.Improve Improve system stability.
    2.Improve memory compatibility.
    3.Enhance compatibility with some USB devices.
  3. I dont have usb boot enabled in bios.
    Bios is updated with the latest version.
    Still no joy
  4. Try using ASUS USB 3.0 Boost on your external drive and see if that helps.
    Download the latest version (1.02.12) from asus website (link in previous post). Its in utilities section.

    Btw. does it work when connected to USB2?
Ask a new question

Read More

Motherboards Computer Boot USB3