Sign in with
Sign up | Sign in
Your question
Closed

ASRock z77 extreme 4

Last response: in Motherboards
Share
July 2, 2012 12:46:56 PM

Hey guys I know i should download the lastest drivers for my new build from the asrock page ( http://www.asrock.com/mb/Intel/Z77%20Extreme4/?cat=Down... )...I know I need drivers for chipset, lan, usb and audio but theres a pretty huge list of diferent drivers on their page and im not sure which are the ones I really need...please help me ASAP...
Thanks

Edit: Its a new build

More about : asrock z77 extreme

Best solution

a c 435 V Motherboard
July 2, 2012 1:26:58 PM
Share

If everything is working, you may not need to update the drivers; windows 7 has many of the drivers in it's files, including the updates. Check windows device manager in the control panel to see if any drivers are needed. Any device with a mark next to it (red, yellow, or ?) means the driver didn't load due to a conflict or missing driver.
July 2, 2012 1:29:29 PM

Oh sorry i forgot to say, Im making a new build...not updating...so i need to download them....i think
Related resources
July 2, 2012 11:45:11 PM

guys i really need help...
a c 435 V Motherboard
July 3, 2012 3:03:36 AM

All the asrock drivers should be on the driver cd that comes with your board. Some have an "auto" feature that installs all the available drivers with one click of the mouse. But most of the device drivers will be loaded by windows 7. So install windows 7 first then check the device manager in the control panel of windows. Any missing drivers will have a mark next to them. If it's clear of marks, then windows found all of the asrock drivers, so you won't need to update them.
July 3, 2012 3:06:01 AM

but are the ones on the disk up to date?
July 3, 2012 3:07:29 AM

ok sorry just read the edited post
July 3, 2012 3:08:02 AM

what if theres still marks after installing windows 7?
a b \ Driver
a c 328 V Motherboard
July 3, 2012 3:48:02 AM

Do u have the mobo and all the parts ready to install?

Are u installing right now?
July 3, 2012 8:31:19 AM

hey I have the same board. I just built a pc myself and didnt have a cd-rom optical drive so couldnt use the cd. I couldnt get LAN to work so I had to use a flash drive to DL the Broadcom driver on another pc and bring it over, and from that point I "thought" I updated the rest ofthe drivers from asrock's page. Yet I have one "unkown device" in device manager. is there any way to identify it?
July 3, 2012 3:23:13 PM

nikorr said:
Do u have the mobo and all the parts ready to install?

Are u installing right now?


Im almost building it, but i wanted to have drivers ready on my usb
July 3, 2012 3:23:51 PM

I dont want to wait for the day all the parts arrive to ask for help because if it happens the same as this thread, it took a whole day for an answer and still not clear
a c 435 V Motherboard
July 3, 2012 3:48:49 PM

Other asrock boards also have the lan driver issue (I've had three of them). Simply load the driver cd after you finish installing windows and select the lan driver only, or install all the drivers if you wish.
July 21, 2012 3:17:26 AM

itsmenando said:
Hey guys I know i should download the lastest drivers for my new build from the asrock page ( http://www.asrock.com/mb/Intel/Z77%20Extreme4/?cat=Down... )...I know I need drivers for chipset, lan, usb and audio but theres a pretty huge list of diferent drivers on their page and im not sure which are the ones I really need...please help me ASAP...
Thanks

Edit: Its a new build



Just use the CD that came with the Motherboard. and download the once that was updated this July. Because the CD that has the drivers was dated April so it means that the drivers included are much updated than the once in their website. I have the same Motherboard.
a b \ Driver
a c 328 V Motherboard
July 21, 2012 2:54:32 PM

Best answer selected by Nikorr.
a b \ Driver
a c 328 V Motherboard
July 21, 2012 2:55:12 PM

This topic has been closed by Nikorr
!