Firefox has no Sound

Alright I have a 7.1 Creative Surround Sound. I have sound coming from all of them in games, and Itunes. But for some reason i cannot hear anything from youtube, gametrailers etc. Firefox is my only browser and I don't want to download another browser. When I got to the control panel and Sound and Audio devices it says "no audio device". Any suggestions on what i should do?
12 answers Last reply
More about firefox sound
  1. If you can't use the dropdown to select a default audio device (creative) then Here's what I would do: Delete the card from Device manager, unistall the drivers. Use Driversweeper to make sure they are all gone. Downwload and reinstall the drivers.

    Let us know how that goes.
  2. Sorry man that won't be happening. Not sure if that was a joke or not lol. The problem is not with the soundcard but Firefox. Like I said, itunes, games etc. work with sound. I disabled all extensions and add-ons and no luck.
  3. What happens when you click on the speaker icon in your tray? Does it bring up a volume slider, with a link at the bottom for the mixer?
  4. Have you tried installing FF v7 over the top?

    Adobe plugins installed?

    Mediaplayer Plugin installed?

    If not .. https://addons.mozilla.org/en-US/firefox/browse/type:7
  5. No theres no link at the bottom for a mixer just says SB Audigy 2 ZS Audio (A400) and I can't click on it. I have all plugins up to date and Im just installing FF v7 right now. Ill reply when I check it out
  6. K tried everything and it still does not work. I don't have any other ideas. I installed Safari and that does not have sound either. I just got Kaspersky Internet Security, would that have anything to do with it? It was working before then I believe.
  7. What O/S are you running?
    Older SB's like the Audigy 2ZS have issues with Win7.
    Just speaking from experience.
    Check device manager for yellow icons in your audio section.
    Kaspersky is good but prone to turn things off in my experience.
    Check our their user forums for similiar issues related to what your experiencing.
  8. Im running on XP. Noob question right here lol, where exactly is the device manager? I know i've seen it a thousand times before I can't remember where though lol. I will check out kaspersky's fourms man. Thanks!
  9. HOLY ****!!!!! Just got it working! I went into the control panel Sounds, Speech and Audio Devices section I clicked on Sounds and Audio Devices. In there it said no Audio Device. I changed it to Audigy 2ZS! Awesome! If that's what you meant by Device Manager. THANK YOU! lol
  10. hunter387 said:
    HOLY ****!!!!! Just got it working! I went into the control panel Sounds, Speech and Audio Devices section I clicked on Sounds and Audio Devices. In there it said no Audio Device. I changed it to Audigy 2ZS! Awesome! If that's what you meant by Device Manager. THANK YOU! lol

    Lol! yep that's what i mean't in around about way not knowing your O/S.
    Rock on:)
  11. popatim said:
    use the dropdown to select a default audio device (creative)


    LMAO, and you thought I was joking....
    Thanks for the grin.
  12. What's with the "18" at the end of every post?
Ask a new question

Read More

Sound Cards Firefox Components