Sign in with
Sign up | Sign in
Your question

6870 framerate issue

Last response: in Graphics & Displays
Share
May 1, 2011 11:34:05 PM

Hello,

I've been researching this issue for days, at least 3, where I was getting low fps in less demanding games, and found out that it was powerplay causing the issue, so I have properly forced the higher clock speeds when I play games but I still notice a light fps drop and intermittent frame skip at various points in-game.

This is really annoying, as games do look better (ie bad company 2) with higher frame rates, but with the intermittent fps drop, it makes gameplay significantly less smooth that it was with my HD 4850, even with the EXACT SAME settings! All this even after forcing the clock speeds using CCC profiles.

I've re-installed the drivers properly, and still haven't noticed a change. Maybe powerplay is still causing an issue, trying to change clock speeds while in game? I'm on the verge of refunding this card completely, as it has been more trouble than it's worth.

CPU: e8400 @3ghz
Memory: 4 gigs
Video Card: Sapphire HD 6870 1gb
19-inch high res monitor
Windows vista 32 bit
PSU: 600w

Btw, I'm pretty sure it doesn't have to do with heat: load temp never goes over 51c, and I've tested with fans at 100% anyway.

More about : 6870 framerate issue

May 6, 2011 6:45:47 AM

HELLO,
I THINK RADEON HD SERIES R NOT ENOUGH POWER FULL FOR HIGH END GAMING I HAVE THE SAME PROBLEM IN CALL OF DUTY 5 I HAVE XFX HD 4650 1GB AND ITS LOT SLOWER THEN MY EXPECTATIONS PLUS IT CANT EVEN RUN RESIDENT EVIL5 ON BOTH DX VERSION IT CRASH ON STARTUP.EVEN IT CANT HANDLE MAX SETTING ON NFS MOSTWANTED AND HALF LIFE 2 THESE R GAMES OF PAST 6 YEARS BUT ATI STILL DROP FPS IN THEASE GAMES.
m
0
l
!