Sign in with
Sign up | Sign in
Your question

Need help with network bridge IP conflict

Last response: in Networking
Share
September 16, 2010 12:08:34 AM

Okay so I'm not the best when it comes to networking... A lot of it still confuses me, but I am better then I used to be.

My basic setup is this... DSL Router (WiFi connection ->) WiFi Card on desktop1 (MAC Bridge ->) Ethernet card on desktop1 (Ethernet cable ->) desktop2.

Normally this setup has worked fine for me before but now that I'm using my friends internet every time the MAC bridge is setup on the first desktop it and the 2nd desktop say "IP address conflict detected" and I can't connect to the internet. It won't even tell me what two things are conflicting which is stupid cause I can't figure out what's having the problems. Their is nothing static on the entire network so I don't see why it's unable to fix this problem itself. So does anyone have any ideas or need more info?

Desktop 1:
MB: ASUS
CPU: AMD K6-2 500MHz
RAM: 512MB (256+128+128) DDR 100MHz
HDD: Seagate Medalist 6GB - IDE 33
WiFi: ALFA Network AWUS036NEH - 802.11B/G/N
Ethernet: Linksys 10/100
September 16, 2010 3:09:33 AM

Could it have something to do with apipa? when you get an ip address from windows it will give out an automatic private ip adress, 169.254.xxx.xxx, and that could be causing an issue.

Or, do you give pc2 a static ip? if so just tell it to automatically find the ip address when you go to another network
m
0
l
September 23, 2010 12:14:45 AM

I don't know what apipa is. :/  As I said I don't know much more than the basics of networking, most of my time goes to the actual computers, I never got into networking much. So could you explain more? And my computer (pc2) isn't using static. I have gotten this setup to work by enabling internet connection sharing so I'm kinda wondering if it'd be better leaving it like this or if their is some advantage to a MAC bridge over ICS.
m
0
l
Related resources
September 24, 2010 1:22:45 PM

sry, its automatic private ip adressing and when your computer is not plugged into a router or is not getting an ip address it will give itself an apipa address, which is 169.254.xxx.xxx.

Try this:
1. Press the start key + R
2. Type in "CMD" and press enter
3. Type in "ipconfig /release" and wait for that to finish
4. Type in "ipconfig /renew" and wait for that to finish

After doing this your computer would have requested a new ip address from the dhcp of the network.

To check this:

1. Press the start key + R
2. Type "CMD" and press enter
3. Type in "ipconfig" and press enter

I'm pretty sure that the computer is giving itself the same apipa ip address as the first computer and that is why you are getting a conflict. Just try doing the ipconfig /release and the ipconfig /renew.
m
0
l
September 24, 2010 4:29:47 PM

It’s difficult to know w/ 100% certainty why this configuration would fail using your friend’s internet since I don’t know what might be different in terms of topology and/or configuration. But the fact that using ICS instead of simply bridging the NICs on desktop #1 does provide a clue.

As described in your example, simple bridging would suffice *if* the DSL router is indeed routing. That is, assigning itself the public IP and creating a local network behind it (e.g., 192.168.1.x). However, if the router was only configured for bridge mode, then it would pass the public IP to desktop #1 and the net effect would be no routing (unless you converted your desktop into a router using ICS).

IOW, one way or another, there has to be a router (hardware or software) if you wish to support more than one desktop w/ a single public IP. If I had to guess, I would suspect the internet connection of your friend is configured for bridge mode, not routing. That’s would definitely explain the duplicate IP messages. No matter how many DHCP requests are made to the ISP, it returns the only public IP available, even if those DHCP requests are from different desktops. As soon as desktop #2 assigns itself the same public IP address as desktop #1, boom, up comes the IP conflict message.
m
0
l
September 24, 2010 5:27:12 PM

I just noticed something while looking through the settings on the router, could having DMZ turned on for PC1 be causing the problems? We turned on DMZ because me and my friend have very different internet habbits, he's a basic Facebook, YouTube, email, that's it guy, while I do torrents, remote desktop connections, online gaming, online storage, and so on so I prefer to have a direct connection to the internet and let my antivirus and firewall control my connection as it makes it easier and less complicated, while he, obviously, is fine with the basic setup and I don't want him exposed to the security risks of a direct connection to the internet. But does DMZ have anything that could be messing up the network bridge?

(The DMZ is setup to reserve the IP 192.168.254.25 (Out of 192.168.254.1 thru 192.168.254.253) for the wifi card on PC1 only (By detecting it's MAC address.).)
m
0
l
September 24, 2010 5:41:20 PM

The DMZ has nothing to do w/ IP conflicts. IP conflicts are created at the time of IP assignment, iow, as part of network configuration. The DMZ is strictly a feature of your router's firewall. Normally the router’s firewall prevents UNSOLICITED traffic from getting into your network. But if you'd like to have that unsolicited traffic always directed to a particular IP on your network, you assign that IP to the DMZ. So again, the DMZ is completed unrelated to IP assignments.

What I find more interesting is that you now seem to be describing a different network configuration for yourself. Initially you described a DSL router (implying you actually are using it *as* a router, not just a modem, which would be the case if it was configured for bridge mode). If in fact you (or your friend) is receiving the public IP at the desktop (i.e., no routing), then you/he *must* use ICS on the desktop if you want the second desktop to share the Internet connection!

m
0
l
!