Sign in with
Sign up | Sign in
Your question

BIOS not recognizing sata ports?

Last response: in Motherboards
Share
July 5, 2012 2:09:17 AM

I have the Gigabyte GA-Z68X-UD3H-B3 motherboard. Everything was working fine on it, then I had to reapply my heat sink bracket (one of the screws got stripped from the mobo when reapplying thermal paste). Now, there are 7 SATA ports on my motherboard. 5 SATA, 2 GSATA. The only one that the BIOS is recognizing are the 2 GSATA ports. So I had to change my cables so my SSD was plugged into one of the GSATA ports so the computer would boot. (Otherwise, I was getting the BOOTMGR file missing or whatever.)

The thing is, once the computer starts, all of my drives are recognized via My Computer. How in the world do I fix this?

Image: https://mail-attachment.googleusercontent.com/attachmen...
a c 174 V Motherboard
July 5, 2012 2:48:05 AM

This sometimes happens when firmware settings are reset. A number of motherboards have BIOS implementations which make SATA ports hard to configure. Many of the motherboards from 2006-2010 are just downright confusing. Since the ports are visible in Windows it sounds to me like the Intel Storage controller's boot ROM isn't being initialized, it is possibly disabled somewhere. Make sure that the controller is in AHCI/RAID mode AND that the controller boot ROM is enabled. AHCI/RAID is preferable to the legacy IDE mode (PATA emulation) and will allow the ports to be used but the boot ROM is necessary to have them usable before an operating system loads its own drivers.
m
0
l
July 5, 2012 11:15:44 PM

Okay, I kind of found the problem, but not quite sure how to fix it, but have an idea.

Whenever I was messing with the settings (and breaking my computer at the same time XD) the mode went back from ACHI to IDE. In IDE mode, I noticed it recognized all my drives in all the SATA ports.

It had the 2 unrecognized before (in ACHI mode) in IDE Channel 0 Master and IDE Channel 1 Master. My guess is for them to be recognized in ACHI they have to be on the same number. (I thought I connected everything back exactly the same, but if this is the case...apparently not.)

And I know I didn't take any of the cords from the PSU out of my drives. So, how do I get both drives on the same number (assuming that's the problem.)
m
0
l
Related resources
a c 174 V Motherboard
July 6, 2012 9:12:38 AM

Tigerbite said:
Okay, I kind of found the problem, but not quite sure how to fix it, but have an idea.

Whenever I was messing with the settings (and breaking my computer at the same time XD) the mode went back from ACHI to IDE. In IDE mode, I noticed it recognized all my drives in all the SATA ports.

It had the 2 unrecognized before (in ACHI mode) in IDE Channel 0 Master and IDE Channel 1 Master. My guess is for them to be recognized in ACHI they have to be on the same number. (I thought I connected everything back exactly the same, but if this is the case...apparently not.)

And I know I didn't take any of the cords from the PSU out of my drives. So, how do I get both drives on the same number (assuming that's the problem.)


I have a couple of old ASUS boards from 2007 which do this; the drives are visibile when in PATA emulation mode / legacy mode / IDE mode (they are all the same) and invisible when in AHCI mode. AHCI is automatic, you may not see the drives in the system setup because there's nothing to do with them.
m
0
l
July 6, 2012 1:41:05 PM

I also noticed that the BIOS does recognize them somewhat (like in the hard drive boot order part, it list all 3 of my hard drives.) But it's weird. Since only the GSATA ports are reading the AHCI drives, if I put my SSD (with the OS) on one of the regular SATA ports, it says BOOTMGR file missing or whatever.

It's not really causing a problem, just a little nuisance now. I set up my work arounds. >_>
m
0
l
a c 174 V Motherboard
July 6, 2012 3:00:22 PM

Tigerbite said:
I also noticed that the BIOS does recognize them somewhat (like in the hard drive boot order part, it list all 3 of my hard drives.) But it's weird. Since only the GSATA ports are reading the AHCI drives, if I put my SSD (with the OS) on one of the regular SATA ports, it says BOOTMGR file missing or whatever.

It's not really causing a problem, just a little nuisance now. I set up my work arounds. >_>


Windows 7 uses a separate partition to facilitate both the PC BOIS and UEFI boot sequences. Similarly, if you have a GPT partition and/or a 32 bit installation this cannot be booted from IDE mode.
m
0
l
!