Sign in with
Sign up | Sign in
Your question

ASRock 970 Extreme help

Tags:
  • ASRock
  • Power Supplies
  • Graphics Cards
  • Motherboards
  • Product
Last response: in Motherboards
Share
July 6, 2012 5:46:33 AM

I honestly have no clue whats going on, I purchased a new power supply. The power supply is the XFX 750W version, everything was working well and what an amazing product. Come back into my room 15 mins later my DVI signal was lost from my graphics card, reset same error. Frustration I began checking connections, tried another reset now...keyboard not functioning and mouse not functioning and still no signal to my monitor. Edit:System powers up fans running.

I have to say I didn't only just install the power supply, I was working on cable management in the back and everything was getting better. Planned to finish it in the morning since everything WAS running.

Any suggestions?

Specs:

CPU: FX 4100 (After market cooling Antec Kuhler 620)
Motherboard: ASRock 970 Extreme 3
Graphics Card: Radeon HD 7850
Power Supply: XFX Pro 750W
Harddrive: OCZ Agility 3
RAM: GSkill Ripjaws

P.S. If i broke my CPU or motherboard let me know so I can just go buy ther parts and get this over with.

Edit:Have been reading around, my graphics card is fine, my ram is fine and its def not my cpu...pretty safe to say its dead.

More about : asrock 970 extreme

a b U Graphics card
a b V Motherboard
July 20, 2012 5:09:23 AM

More then likely its the Mobo, But try a different PSU if you havn't fixed your problem yet.

I have the same board but with the Phenom II x6 1100T and had it clocked to 4.1ghz and was rock solid at temps just above 62c. I didn't like the temp so I lowered to 4ghz. The board is great for its price.
m
0
l
!