Sign in with
Sign up | Sign in
Your question

Need automatic fan control for ATI Radeon HD 5770

Last response: in Graphics & Displays
Share
May 7, 2011 4:08:45 PM

I just upgraded from an nVidia GeForce 8800GT to an ATI Radeon HD 5770, specifically the Sapphire Vapor-x model. With the 8800GT, I was able to use the famed RivaTuner to set up automatic fan control. When the temperature increased while playing a game, the fan would spin faster to compensate. RivaTuner no longer works with my HD 5770, probably because the software hasn't been updated since 2009. It does not show the temperature graphs or let me control the fans anymore. So I moved on to another popular monitoring tool, MSI Afterburner. Manual setting of the fan works, but auto fan control does not. As you can see from the screenshot, the current temperature is 37 C, the auto fan graph shows 37 C should map to approximately 44% fan speed, but the actual fan speed is still stuck at 36%. Can I make this work in MSI Afterburner or is there better software elsewhere?

I have the newest GPU drivers and I'm using Windows Vista 64 bit.

May 7, 2011 4:16:56 PM

tokyotech said:
I just upgraded from an nVidia GeForce 8800GT to an ATI Radeon HD 5770, specifically the Sapphire Vapor-x model. With the 8800GT, I was able to use the famed RivaTuner to set up automatic fan control. When the temperature increased while playing a game, the fan would spin faster to compensate. RivaTuner no longer works with my HD 5770, probably because the software hasn't been updated since 2009. It does not show the temperature graphs or let me control the fans anymore. So I moved on to another popular monitoring tool, MSI Afterburner. Manual setting of the fan works, but auto fan control does not. As you can see from the screenshot, the current temperature is 37 C, the auto fan graph shows 37 C should map to approximately 44% fan speed, but the actual fan speed is still stuck at 36%. Can I make this work in MSI Afterburner or is there better software elsewhere?

I have the newest GPU drivers and I'm using Windows Vista 64 bit.

http://i.stack.imgur.com/6rDEC.png


Did you open up the settings, go to the profile tab, and assign a saved profile to the 2D and 3D settings?
m
0
l
Related resources
May 7, 2011 5:26:51 PM

Seems like I needed to hit the "apply" button for it to work.
m
0
l
May 7, 2011 7:50:00 PM

Ah ha! :p  good you got it going.
m
0
l
!