Sign in with
Sign up | Sign in
Your question

Antec Earthwatts 500w with Z77x

Last response: in Motherboards
Share
July 9, 2012 9:58:53 AM

Hey guys,

I recently bought a Z77X UD3H. Everything is installed, just the cables are not plugged in to the motherboard.

I am using a Antec Earthwatts 500w PSU, and I've been looking up instructions just hoping someone had made one. No luck.
The cables don't fit together, I've compared it with my old motherboard, a P5K Pro, everything fits perfectly on that computer.

Is it possible to use these two together? I don't really want to have another trip to the stores again, I've been there for about 5 times in a row for the past week. Not very happy.

Thanks guys.
a c 435 V Motherboard
July 9, 2012 4:47:20 PM

The antec should have a standard 24 pin connector and either a 4 or 8 pin 12v connector for the port next to the cpu. A 4 pin connector will sometimes work fine in the 8 pin port, if that's what your board has. I've even used a 20 pin connector on a 24 pin port with no problems. Check to see if 4 pins of the 24 pin were separated for usage on your old board, and snap them back in place if needed to make 24 pins again.
m
0
l
July 10, 2012 4:10:09 AM

o1die said:
The antec should have a standard 24 pin connector and either a 4 or 8 pin 12v connector for the port next to the cpu. A 4 pin connector will sometimes work fine in the 8 pin port, if that's what your board has. I've even used a 20 pin connector on a 24 pin port with no problems. Check to see if 4 pins of the 24 pin were separated for usage on your old board, and snap them back in place if needed to make 24 pins again.


The problem is, I don't know which cables go to what pin. The cables aren't even labelled >_<
m
0
l
!