Sign in with
Sign up | Sign in
Your question
Closed

Full screen video - Black screen for a few seconds

Last response: in Graphics & Displays
Share
May 8, 2011 2:45:01 PM

I have an extreme annoyance here, and that is *almost* every time I full screen a video, whether it be a file or a YouTube video my screen goes black for a few seconds, completely cuts out sort of thing, then when I exit the full screen of the video - same thing happens. Quite frankly its driving me nuts.

I know there is a workaround for flash players, disabling hardware acceleration, but I want a real fix for this for my whole PC.

It started happening when I got myself a new graphics card, upgraded from an ATI 5770 to a Nvidia 580 - at the time I was dual monitoring, strange thing is full screening on the second monitor was fine, normal as could be, but full screening on my main monitor (now my only monitor) is acting up as I described. I uninstalled the old ATI drivers (to my knowledge) before installing the new Nvidia drivers, so I'm not sure if theres still some remains of that screwing me up - and I have no idea how to check.

Games etc. work more than fine the card is great and is in no way faulty - it's just when I full screen and exit full screen on most videos, either online or actual files on my PC.

Hope theres a REAL fix out there, only thing I've been able to come across is the disabling hardware acceleration workaround, and maybe it's me just wanting to see something wrong but when I do disable it it looks a hell of a lot worse.

Thanks!
December 18, 2011 7:53:06 AM

CerberuX said:
I have an extreme annoyance here, and that is *almost* every time I full screen a video, whether it be a file or a YouTube video my screen goes black for a few seconds, completely cuts out sort of thing, then when I exit the full screen of the video - same thing happens. Quite frankly its driving me nuts.

I know there is a workaround for flash players, disabling hardware acceleration, but I want a real fix for this for my whole PC.

It started happening when I got myself a new graphics card, upgraded from an ATI 5770 to a Nvidia 580 - at the time I was dual monitoring, strange thing is full screening on the second monitor was fine, normal as could be, but full screening on my main monitor (now my only monitor) is acting up as I described. I uninstalled the old ATI drivers (to my knowledge) before installing the new Nvidia drivers, so I'm not sure if theres still some remains of that screwing me up - and I have no idea how to check.

Games etc. work more than fine the card is great and is in no way faulty - it's just when I full screen and exit full screen on most videos, either online or actual files on my PC.

Hope theres a REAL fix out there, only thing I've been able to come across is the disabling hardware acceleration workaround, and maybe it's me just wanting to see something wrong but when I do disable it it looks a hell of a lot worse.

Thanks!



I was wondering if you ever got anything working. I'm literally having the exact same issue, with the exception that my old ATI card was a 5850.
Score
0
December 25, 2011 8:41:35 AM

Shwingdom said:
I was wondering if you ever got anything working. I'm literally having the exact same issue, with the exception that my old ATI card was a 5850.


Nah sorry its still exactly the same for me. Just living with no hardware acceleration for flash videos and using my TV as a second monitor for like .avi's etc. It's annoying and I do want to reformat but I have like 800+gb worth of games on this PC and no where to back them up to, so to this day I still haven't reformatted to see if it works. :( !
Score
0
Related resources
December 25, 2011 9:24:36 AM

I actually just figured mine out.... I feel like an idiot.

Start -> control panel -> Display -> change display settings -> advanced settings -> monitor -> set refresh rate to 60 hz

For some reason my monitor "supports" 59 hz and that's what it was set to, but it's really 60hz native. I picked 60hz and hit apply... instant fix. I about crapped myself because it was bothering me for weeks on a brand new build. Needless to say I was pretty angry it was something so stupid.

Hopefully this helps you.
Score
0
December 25, 2011 9:40:19 AM

Ah you may be onto something! Unfortunately as soon as I click apply mine goes right back to 59...... If only I could figure that out, thanks for the clue in the right direction though!
Score
0
December 25, 2011 9:42:41 AM

the drop down menu goes back to 59 on mine as well, but it's still set to 60.
Score
0
December 25, 2011 10:18:09 AM

Ah then this doesn't work for me unfortunately. Thanks anyway :p 
Score
0
!