Sign-in / Sign-up
Your question

Can't configure my Physx - (PLEASE IM DESPERATE)

Tags:
  • Nvidia
  • Configuration
  • Physx
  • Graphics
Last response: in Graphics Cards
May 11, 2011 11:28:08 AM

Okay, so I get this awesome-looking game(called Divinity II), and my heart fell(like it did when I discovered that I can't play Mass Effect 2)... It had an error about my Physx software.

And so you ask: What's this got to do with the "can't configure Physx" blah, blah, blah??

Well, I did a little investigating and saw that I can play the game if I disable the Physx accelerator! (I was like, Hooray!!) And then, the guide said that I have to get to the 'Set PhysX configuration' tab to disable said accelerator... I said to myself, hey this'll be easy. But when I got to the Control Panel, there's no "Set PhysX configuration"!!! :cry: 

I don't know what to do now.. I have Physx software! And yet there's no Set PhysX configuration tab in my Nvidia control panel!! I don't think I can reinstall/update my drivers because I tried that a couple of times, and they all ended badly(with me having to reboot an image so that I won't loose the Nvidia software)...

My Nvidia card is a GeForce 310m...

Screenshot:

More about : configure physx desperate

May 11, 2011 11:39:30 AM

eva002 said:
Okay, so I get this awesome-looking game(called Divinity II), and my heart fell(like it did when I discovered that I can't play Mass Effect 2)... It had an error about my Physx software.

And so you ask: What's this got to do with the "can't configure Physx" blah, blah, blah??

Well, I did a little investigating and saw that I can play the game if I disable the Physx accelerator! (I was like, Hooray!!) And then, the guide said that I have to get to the 'Set PhysX configuration' tab to disable said accelerator... I said to myself, hey this'll be easy. But when I got to the Control Panel, there's no "Set PhysX configuration"!!! :cry: 

I don't know what to do now.. I have Physx software! And yet there's no Set PhysX configuration tab in my Nvidia control panel!! I don't think I can reinstall/update my drivers because I tried that a couple of times, and they all ended badly(with me having to reboot an image so that I won't loose the Nvidia software)...

My Nvidia card is a GeForce 310m...

Screenshot:
http://imageshare.web.id/images/wtzxmg45p7sd8y0z5r80.png

This worked for me.
1. Uninstall Phyx.
2.Install Phyx from disc (i mean from ME2 or other game.) if possible. Then restart. If its not bundled then Download it from Nvidia. Restart

If problems persist i'm not sure. Thats what i did to get it too work. No idead why it did it in the first place.
m
0
l
May 11, 2011 11:54:09 AM

I already did that... (a long time ago actually) Nothing seems to work for me.. Nvidia HATES me... :cry: 



Also, I got Divinity II to work, with my other video card. But MAN. I'm running in lowest of the low configs for the game, and my fps hasn't risen from 10...
What worries me most is the Physx... Does this mean I'm forever forbidden to play Physx games to my heart's content??!?! :cry:  :cry:  :cry: 
m
0
l
Related resources
a c 904 Î Nvidia
May 11, 2011 3:29:20 PM

Divinity 2 is not a GPU accelerated PhysX game. But if you need to disable PhysX, the way to do it in the Nvidia Control Panel is to set the PhysX configuration to "CPU".
m
0
l
May 11, 2011 5:16:32 PM

According to Nvidia's features pages, the 310M and 315M aren't supported. I mean c'mon ... they only have 16 CUDA cores. That can't be enough horsepower to run PhysX in addition to regular game graphics. The 410M is the lowest model that shows that it supports PhysX, and it has 48 CUDA cores.

That is likely why the required control panel tab isn't there -- the feature isn't supported.

I could be wrong. Maybe there's some sort of hotfix out there enabling PhysX on those weak notebook GPUs.

Source:
310m page Click the link, then click the Specifications tab. No entry for PhysX.
410m page Click the link, then click the Specifications tab. Note the entry for "NVIDIA PhysX™-ready."
m
0
l
a c 109 Î Nvidia
May 11, 2011 5:33:14 PM

Matto27secs is right. Divinity II doesn't use accelerated GPU physX. You just need the drivers installed because they do use a little physX on the CPU.
m
0
l
May 12, 2011 1:40:54 AM

To be honest, with a problem like this my first action would be a reformat and reinstall. An incomplete graphics card driver install can wreak all kinds of havoc. And I say to reformat because the "copy over the existing version" type of install might not clear out the problem.
m
0
l
May 14, 2011 1:30:34 PM

Gah.. Then I'll have to contact *** pro? But what makes you think my graphics card driver is incomplete?


@Matto27secs & bystander: Then maybe what Leaps-from-Shadows said about my graphics driver being incomplete is true? Because I just bought Risen, installed it perfectly, no errors, but I can't run it with my Nvidia card... I ran it with my crappy integrated graphics card and guess what? It freakin' ran without problems. Well.. Except maybe the constant less than 15 fps I get when playing Risen...
m
0
l
a c 904 Î Nvidia
May 14, 2011 4:01:20 PM

Do a proper uninstall of your current Nvidia card driver, restart, then install the latest driver from the Nvidia website using the "Clean Install" option. Be sure to check the box to install PhysX software.
m
0
l