Gaming not smooth with radeon 5970

My systerm configuration :
Phenom 2 x4 965 BE
4 GB Memory
RadeonHD 5970
Gigabyte GA-890GPA-UD3H Board
OCZ Vertex 3 128 GB SSD
WD 1 TB HDD

But when I play Badcompany 2 in high resolution, It is not smooth....some times the frame rate goes to 0 or below 10 and goes up to 60. Any ideas about why it's not smooth?
28 answers Last reply
More about gaming smooth radeon 5970
  1. What about the other games?
    Already has the latest version of driver?
    Where did you installed the game? On hard disk or SSD?
  2. I don't have any other games. Yes the driver is latest. And the game is in SSD. I tried with reducing the graphics settings, but no difference.
  3. Your probably bottlenecked by your CPU.Try O.C.ing a few 100mhz and see if that cures it.The 5970 is a really powerful card still and if you don't match it is CPU power it will just get bogged down.
  4. I wonder if 4GB's of ram would have an effect on a Crossfire setup like that. I know I've seen an article about the sweet spot for ram, and it's moved up to the 6-8GB area now, based on their tests.
  5. Have you OCed you cpu?
    What is your PSU?
  6. Never did OCing.. and PSU is Corsair850. And one important thing before adding the SSD it was working fine.... Problems started with SSD. I tried with removing SSD and played the game from HDD but didn't help. Removed the HDD and played from SSD only, also not good.
  7. I'd added the SSD without disconnecting my HDD. Will it make a problem? And also when I change the mode to AHCI , while booting, shows a message that no AHCI drivers found.
  8. No AHCI drives found message. I'm not able to edit the previous message. :)
  9. that's only driver problem, what is ur OS... have u remove previous Graphic Driver?if not, sweep your all video driver by driver sweeper and install again....
  10. No it won't matter if you unplugged the old HDD or not.

    Did you download the newest drivers for the 5970 on the SSD?
  11. Yes I use driver sweepr before each installation and I use latest CCC. And OS is windows 7 home premium.
  12. I have the same set up as you, a SSD and also a HD5970. I get stutter effect when i connect to the server and then it goes away. There are however problems with one or 2 severs where the frps goes really low but as it is only one or 2 of the servers i believe it is an issue their end.

    are you having this problem on all servers or just the one you usually use also have you had any issues with any other games?
  13. Richard226 said:
    I have the same set up as you, a SSD and also a HD5970. I get stutter effect when i connect to the server and then it goes away. There are however problems with one or 2 severs where the frps goes really low but as it is only one or 2 of the servers i believe it is an issue their end.

    are you having this problem on all servers or just the one you usually use also have you had any issues with any other games?

    Welcome to the club :) While playing, if i move quickly or look around very fast, I can see the frames reducing. It was not like that before. This is the case regardless of the server. I got pain to my eyes becasue of this :(
  14. my issue is only on the first time i connect to the server and speaking to people it seems to be a wide spread issue. I would more likely assume that it is your connection rather than the card. Have you tried running some graphics tests on it?
  15. I tried with fur mark and saw that the frame rate is around 8 with high settings...
  16. Check ur CPU usage in task manager, perhaps another thread is being process.
  17. subinjose said:
    I tried with fur mark and saw that the frame rate is around 8 with high settings...


    You might want to be more detailed about your results. What furmark test did you take (there are a lot). And rather than using high settings on furmark, use the default performance tests. We can help you out more.
  18. This is the result of the furmark test I did :

    Score: 3600 points (59 FPS)
    Submitted on May 14 2011, 9:34 am

    Bench duration: 60 seconds
    Resolution: 1920 x 1080
    MSAA samples: 0
    Window mode: fullscreen

    Primary renderer: ATI Radeon HD 5970
    Device ID: 0x1002 - 0x689c
    GPU clock: 700 MHz
    Memory clock: 667 MHz
    Graphics drivers: Catalyst 11.4 - 8.841-110405a-116954C-ATI (4-5-2011)
    GPU temperatures (start/end): not available
    Number of GPUs: 2

    CPU: AMD Phenom(tm) II X4 965 Processor
    CPU speed: 3415 MHz
    Operating system: Windows 7 64-bit build 7600 [No Service Pack]
  19. If i over clock my Phenom to 4GHz will it increase the gaming performance ?
  20. Slightly.Your CPU is not causing this,we must look elsewhere for a soultion.
  21. I played the game with medium settings , but no change... I can see clutter in the display.
  22. If it's not the drivers,PSU or the CPU then maybe it's the card.Thats the only other thing I can think of.Your computer is fully capable of running of runn the 5970 at pretty good speeds.

    But what boggles me is that you said everything was working fine and smooth before using the SSD but after you installed it it wasn't working anymore and you tryed to switch it back but somehow it still wouldn't work.Try reinstalling Windows and the 5970 drivers and see if that works.Also make sure you delete the other copy of the game on the other HD your not using.
  23. When the frame rate reduce I can hear the sound of CPU fan reducing. And after 2 seconds it comes to normal rate again.
  24. Try disabling AMD Kool&Quiet in the BIOS.Thats going to stop the CPU from downclocking when idling and it might give you more power when your gaming.
  25. Is it just me or it sounds like some kind of software bug. Im only 13 so i dont know :D

    But anyway, would any1 recommend me to buy HD5970 for future for resolution of............................................1280*1024? :D
  26. Go to Catalyst Control Center... in Gaming tab, click default and apply......
  27. Turn Off Power Now and C1E CPU support, the computer is trying to use less power when less CPU power is needed, resulting in HUGE frame rate spikes, i experienced the same thing with my 955. Battlefield Bad Company 2 does this more so than other games because its game engine (frostbite) can use 1% CPU power or up to 100% at random given points in time given something physics wise is occurring in game.

    @RobisssLV, go with a HD 6850 or 6870 for such a low resolution. a 5970 is above overkill.
  28. The 5970 is still greatly overpriced for it's performance.
Ask a new question

Read More

Graphics Cards Graphics Product