Sign in with
Sign up | Sign in
Your question
Closed

Catalyst install manager failed to initialize detection manager

Last response: in Graphics & Displays
Share
May 13, 2011 1:54:47 PM

catalyst install manager failed to initialize detection manager

HD 5770 windows 7 32 bit
Trying to update my driver from 11.3 to 11.5
I have uninstall old software, safe mode driver sweeper, disabled antivirus, no dice.


Error log

Existing packagesATI Catalyst Install Manager
AMD APP SDK Runtime
ATI Display Driver
HDMI/DP Audio Driver
Microsoft Visual C++ 2010 Redistributable
AMD Drag and Drop Transcoding
WMV9/VC-1 Video Playback
Catalyst Control Center 2


Other detected devices

Error messages
Catalyst™ Install Manager failed to initialize Detection Manager

version 11.3
CCC not showing in add/remove programs,
ATI install manager is showing in add/remove programs.
Can't load CCC at all. CCC.exe is running in my system process along with atieclxx, mom, atiesrxx, amd reservation manager.exe

May 14, 2011 3:53:32 AM

Try CCleaner and install CCC as Admin.
You have to dump ATI install manager for complete removal in add/remove.
Then do your DS in safemode.
Score
0
May 15, 2011 1:51:52 PM

So i did as you said. Start, control panel, programs and features, CCC was not listed but amd install manager is. Right clicked, change, uninstall. Got same error message "catalyst install manager failed to initialize detection manager" Hit ok and proceeded. After, it was still listed. Right clicked again, change. Said it was un-stalled then it was removed. System did not ask to reboot nor did device manager show the driver uninstalled.

Rebooted safe mode. Ran driver sweeper. Removed all ait drivers and such.

Rebooted normally. System did not tell me a new hardware was detected although device manage did recognize the hd 5770 with a problem, right clicked, deleted, ran ccleaner.

Rebooted safe mode, ran driversweeper again

Rebooted normally, ran ccleaner again. tried to install 11.5 same error "Catalyst™ Install Manager failed to initialize Detection Manager" Tried to install drivers from the CD the hd 5770 cam with, same error.


The only way i can get the 5770 to run at all is to run a system restore and even then, CCC driver 11.3 wont show in programs and features and i cant load it up although it is running in system processes.

Ran everything as admin.
All security software was disabled through the whole process.

So lost on this, really need some help.
Score
0
Related resources
May 15, 2011 7:40:49 PM

Have you tried uninstalling it in safemode add/remove?
I use REVO uninstaller for pesky programs add/remove doesn't dump.
Score
0
May 15, 2011 9:25:05 PM

So i tried revo uninstaller. Uninstalled amd install manager, cleaned left behind files/registries, rebooted safe mode, driver seeper, rebooted, ccleaner, tried to install driver, got same error.

I tried iobit uninstaller 2 beta. More amd/ati programs where listed such as amd app sdk runtime, ati avivo codecs, and catalyst control center-branding were listed. To no aval, iobit failed too. Thank you for trying to help :) 



Score
0
May 16, 2011 11:35:24 PM

Anyone have any ideas?
Score
0
July 15, 2011 3:08:18 PM

CCC v11.6 corrected my issue
Score
0
July 15, 2011 4:05:25 PM

This topic has been closed by Mousemonkey
Score
0
!