Sign in with
Sign up | Sign in
Your question

New Sabertooth 990fx - no reaction

Last response: in Motherboards
Share
July 13, 2012 6:01:43 PM

Hello all,

I'm having problems with a recently bought Asus Sabertooth 990fx. I get no reaction from the board whatsoever, except for the green power LED.
I bought the Asus board as an upgrade to my old Gigabyte MA770T-UD3P. All the other components work fine with the old board, which in fact I now reinstalled.
Basically the only thing changed in my setup is the motherboard. I'm not sure if the new Asus board is damaged either, it's actually the second one i'm trying to get to work, i already returned another with the same symptons.
I'm a bit at a loss here what the problem could be, especially since everything is running fine with the Gigabyte board.
Any help would be greatly appreciated.
a c 117 Ĉ ASUS
a c 466 V Motherboard
July 13, 2012 6:33:36 PM

i would look to see if your cpu on the cpu supported list of the new mb. if it is look at the mb make sure you have both the 24 pin and the 4/8 pin power plug plugged in. if you do look when you turn on the power supply and hit the on switch does the red ram let come on and blink. if it on hard and the fans dont spin...try removing on ram dimm. if no change try moving the dimm to another spot.if not change see if the ram on the mb qal list. if it is and the led does not come on and no fan is moving you may have shorted the mb to the case.
a c 269 Ĉ ASUS
a c 1032 V Motherboard
July 13, 2012 6:37:03 PM

Did you use the Asus Q-connector kit.
Related resources
July 13, 2012 7:03:46 PM

Thanks for the quick replies.
24/8 pin plugs are plugged in . If I turn on the power, i get no fans spinning, no red LEDs either.
I'm using 4x 4 GB Corsair ram (CMX9GX3M2A1333C9) which is on the supported list. The cpu is a Phenom II X4 955 (HDZ955FBGIBOX), which is also supported. The PSU is an Enermax Liberty ELT500AW, the graphics card is a Sapphire 7750 Ultimate.

I already tried using only 1 ram in slot A2, as per Asus' suggestion, no luck.
I havn't used the Q-connector kit yet, I might try that next. Will report back later how that went :) 
July 13, 2012 8:21:47 PM

Ok, quick update:
I reassembled the Sabertooth outside the case, using only the CPU, 1 ram and the graphics card, still nothing.

The only thing i can think of now is the PSU. Could there be problems, altough it powers the same setup with the old board just fine?
a c 269 Ĉ ASUS
a c 1032 V Motherboard
July 13, 2012 10:55:11 PM

Q-connector kit < Did you try it?
July 14, 2012 12:28:18 AM

esco997 said:
24/8 pin plugs are plugged in

Is there a 4 pin connector the CPU as well? If there is, it HAS to be plugged in.
July 14, 2012 6:00:27 AM

SR-71 Blackbird said:
Q-connector kit < Did you try it?


Yes, used the Q-connector kit.

JohnJones said:
Is there a 4 pin connector the CPU as well? If there is, it HAS to be plugged in.


There is a 8 pin EATX connector, it is plugged in.


July 14, 2012 10:54:18 AM

Update: I tried the board with another PSU and it's working now. Weird that the PSU would work with one board and not the other. Buying a new PSU now.
Thanks for helping all.
a c 269 Ĉ ASUS
a c 1032 V Motherboard
July 14, 2012 12:58:50 PM

Glad your up and running!
!