Sign in with
Sign up | Sign in
Your question

Problems with ASRock z77 RAID and Intel RST

Last response: in Motherboards
Share
July 14, 2012 12:21:42 AM

I'm having problems maintaining a persistent RAID volume on my new build. The closest I am able to get is being able to create a working RAID volume in the Windows RST UI, but everything fails after I reboot the PC.

I have an ASRock z77 extreme4-m, 3570k, a Vertex 4 128gb SSD boot drive, and three 500gb HDD's, Windows 7 Ultimate 64bit, SeaSonic x650 psu, XFX DD 6870

I have the Intel Controller set to RAID with my ssd and three hard drives plugged in to it on ports 0-4. I have my DVD drive on the AsMedia controller set to AHCI on port 0.
All drives are ALWAYS recognized in BIOS
I am running the latest ASRock BIOS v1.20
I have tried installing windows with AND without install the Intel F6 RAID drivers

I have tried creating my RAID volume before installing Windows, using the RST ROM after that pops up after POST
I have also tried creating the volume AFTER installing Windows, using the RST ROM
... All instances of using RST ROM result in not being able to see the drives in 'My Computer' AND Disk Management failing to initialize any of the hard drives. Disk Management says 'the system cannot find the file specified' when trying to initialize as a MBR.

I am able to create a working RAID volume if I go to the RST ROM and change the drives to non-raid members. Then going to the WIndows RST UI and creating the RAID volume from there. Then going to disk management and partitioning the volume and formatting it to NTFS. This results in a working RAID volume. HOWEVER, the RAID volume fails after I reboot the PC. Notice this image. https://dl.dropbox.com/u/17851743/Photos/RAIDfailure.PN...

I have run chkdsk on all hard drives and have ran Spinrite on all the hard drives with no problems. Spinrite has no problem controlling the drives.

Also, my DVD drive fails to load an Ubuntu LiveCD when I select 'try ubuntu'. Resulting in this screen. https://dl.dropbox.com/u/17851743/Photos/2012-07-13%201...
Hard to tell from the picture, but it's a glitchy/static screen.

I am able to reproduce everything above with AND without performing a Windows Update and installing the motherboard drivers.
I have also stripped the PC down to the essentials and everything acts the same.

Am I doing something wrong? Or could this be a motherboard or cpu defect? I'm still within my 30 day replacement period with Newegg. I have been trying to figure this out for at least 4 days and am getting pretty stressed out about it. Any help or ideas as to what's wrong will be greatly appreciated. Thanks.
November 25, 2012 7:19:02 AM

Hi, i have exactly the same problem, in my case its driving me mad. I have 3 500GB hdds runing in raid 0 as boot drive. I can create the raid from the bios, then i even install windows 7 64x(windows 8 instalation fails with this fancy new bluescree). It makes no difference whether i load the vendor drivers for raid or not. After first boot after successful w7 installation, randomly 1 or more disks from the raid are marked with error, the disks are new and i have checked them separtely for failures, they are ok. I gues its intel raid issue on this particular motherboards. My is Z77 Extreme 6. And it happened on the old bios exactly the same way as on the newest one(2.30 i guess). It would be great if soemone has explanation for this.
m
0
l
November 25, 2012 11:19:10 AM

What ports do you have the drives plugged in to?

I never found a solution to this. I ended up buying a RocketRaid 622 to RAID my HDD's externally.

I also couldn't get IRST + my RocketRaid to work together. I was trying to run a RAID0 of SSD's using IRST and a RAID10 using my RocketRaid. PC would load both RAID bioses and say everything was normal, then it would freeze at the AsRock screen. Couldn't get to BIOS or the boot menu unless I unplugged either the sata ports on my mobo OR the esata port on my RAID card.
m
0
l
Related resources
November 26, 2012 6:37:38 AM

Got them in SATA2_2 SATA2_3 and SATA2_4 so all on intel controller dont want to mix the controllers for one raid array.
Now after day of intensive testing(memory modules swap, power source swap etc.) it seems to be power problem. I had all of the three disks on one power cable, and this could explain the failure of random disk, didnt have enough power, later start etc.
I split the disks to two separate power nodes and since them everything is running green. So RAID 0 from 3x Sata2 disk is working now for me. I'll keep u updated after a week or so when the stability of this will/will not be prooved.
m
0
l
November 26, 2012 9:15:35 AM

Oh wow. I never thought of that. I was doing the same. What power supply are you using? I was using a Seagate x650.
m
0
l
!