Sign in with
Sign up | Sign in
Your question

USB issues: Cannot install Intel USB drivers

Last response: in Motherboards
Share
July 14, 2012 8:38:30 PM

Hello,

I have an ASRock Extreme4 MB that seems to be having issues with some USB devices that are plugged into it. It's most evident with my mouse as the it seems like the USB slots lose power or connection at random times. For example, my mouse has lights on it. I'll be using my computer as normal and out of nowhere I'll lose control of my mouse and see that it's lost power(no lights). After a few seconds, it will reconnect and Windows will make it's "found hardware" noise and the mouse will resume working.

I've tried reinstalling the USB drivers for the board but I'm having issues. When I look at the device manager I notice that there is a yellow flagged unknown device. I tried using my MB's driver CD to install the drivers and it tries to install the Intel USB 3.0 eXtensible Host Controller driver but says it encounters an issuer when trying to install. (I tired installing the newest drivers from ASRock's website and their drivers won't install either) It goes on to say, "Cannot create a stable subkey under a volatile parent key".

So basically, I think that's what's causing my issues with the devices plugged into my USB ports(I've tried changing ports and it doesn't help). I can't install the drivers for the "Intel USB 3.0 eXtensible Host Controller"

Does anyone know how I can fix this or what is causing this? I'm using Windows 7 64. If there's any other info you need, just let me know. Thanks for any help.
a b \ Driver
a c 328 V Motherboard
July 14, 2012 8:43:11 PM

Whats the OS?
July 14, 2012 8:54:01 PM

nikorr said:
Whats the OS?


Windows 7 64. I put that at the bottom of the first post. Let me know if there's any other info you need.
Related resources
a b \ Driver
a c 328 V Motherboard
July 14, 2012 8:56:53 PM

Is it the Z77?
July 15, 2012 2:15:39 AM

nikorr said:
Is it the Z77?



Yup.
July 15, 2012 2:20:28 AM



I tried installing both of those drivers for the USB. The Intel driver will not install. The ASMedia driver does though.

When I try to install the Intel driver, it just stops and says there was an error when trying to install. When I try to install the drivers from the driver disk that came with the MB, it does the same. When I try to update the drivers through device manager(which is giving me the yellow flag), it gives me the response that I put in my first post,"Cannot create a stable subkey under a volatile parent key". I have no idea what this means.
a b \ Driver
a c 328 V Motherboard
July 15, 2012 2:30:07 AM

Uninstall, repair .net 2.0, reboot, then re-install the driver.
July 15, 2012 4:03:17 PM

Well, I was going to try your suggestion with the .NET and when I went looking for it to uninstall it, I saw that the Intel USB extensible Host Controller was listed in the uninstall list in the control panel. I'm guessing it was corrupted when it first installed when I built this PC a month ago. Not quite sure.

Whatever happened, it wasn't installed enough to show up on device manager and it prevented me from installing a newer version. That's why I never even bothered to look at uninstall. I didn't even think it was installed.

So I uninstalled the old one, tried reinstalling the newest version from Intel and it actually fully installed this time. When I go to device manager, I don't have the yellow flag anymore and it shows the Intel USB 3.0 extensible host on the list.

I'm hoping this fixes the issue with the mouse momentarily turning off and on. If this doesn't fix it, I have no idea what to try next. It's not just a mouse issue because I've had the keyboard do the same thing (the keyboard is lit up too and it'll momentarily go out).

Anyhoo, I greatly appreciate your help. While your suggestion may not have been the thing that allowed me to install the drivers, it got me to look in the right direction. I just hope it's fixed. I'll let you know if not.

Thanks
July 15, 2012 6:48:06 PM

Well, there went that theory. It's still doing it. I have no ideas left. I'm not sure what I should even try next.
July 16, 2012 6:02:37 PM

Does anyone else have a theory?

I've tried different USB ports, I've made sure there's a clean connection, I've made sure it's completely in the USB. This is very annoying.

I really feel this is probably a software issue. I don't remember this PC doing this until maybe a week or two ago and the PC's about a month old.
!