Sign in with
Sign up | Sign in
Your question

Compaq Cq61-410us blank screen

Last response: in Components
Share
October 19, 2011 1:49:51 PM

Hello Everyone

I have a Compaq Cq61-410us laptop,its 1 years old.Yesterday i was playing a game on it and screen just freezed for a moment and then laptop got shutdown automatically,i just ignored it,and restarted it,after few hours it again got shut down after showing me a light green screen.
I restarted it and after 1 hour when it was on a idle screen,whole screen went green,then red, then light blue,and then green with black lines in it.After then it is not starting up.When i press power button it lights up,wifi button is also showing red light,fan is working too,Caps lock and Num lock keys are blinking after every 2 seconds,nothing is coming up an the screen.
Please help me,was not easy for me to buy it and i am bit afraid to take it to repair center.Any help would be greatly appreciated.
October 19, 2011 3:09:17 PM

sounds like either the screen ribbon is faulty or the graphics chip is overheating or worst case the actual lcd screen is faulty

try connecting an external monitor if that works ok then i would suspect the screen ribbon--this is a cheap and reasonably easy repair if you are at all practical--if external screen is the same then its the graphics chip unfortunately and usually means a new motherboard

could still be the lcd but the ribbon is much cheaper so i would always try that first
m
0
l
October 19, 2011 6:16:46 PM

Hello mcnumpty,i did as u said.and connected it to external lcd but it didn't worked.because cpu is just not starting up,a small light which blinks with usage of cpu is just blank..what should i consider now?
m
0
l
Related resources
October 19, 2011 6:17:40 PM

Hello mcnumpty,i did as u said.and connected it to external lcd but it didn't worked.because cpu is just not starting up,a small light which blinks with usage of cpu is just blank..what should i consider now?
m
0
l
October 19, 2011 6:19:30 PM

Hello mcnumpty,i did as u said.and connected it to external lcd but it didn't worked.because cpu is just not starting up,a small light which blinks with usage of cpu is just blank..what should i consider now?
m
0
l
!