Echo in sound

Hello,
i looked for the answers for the echo sound i have in my acer labetop travel mate 5740 and tried everything to solve it in the control panel but nothing is useful, please help me have clear voice again , the headset doesnt make any echo, clear voice in headset.
2 answers Last reply
More about echo sound
  1. The sound icon should be in the lower right hand side of the taskbar in the hidden icons section. Be sure it's set to default. I changed my settings, and now get an echo in my golf game, but I don't mind it.
  2. thanks for your reply but this is not the issue, i am not sure but it can be something with the hardware.. still trying to know how to solve this issue.

    thanks for any help can be given..

    kholoud
Ask a new question

Read More

Sound Cards Control Panel Gaming Headsets Acer Components