Sign in with
Sign up | Sign in
Your question

Low FPS issues on World of Warcraft

Last response: in Graphics & Displays
Share
May 16, 2011 9:14:38 AM

Hi, I am experiencing low fps, my latency is fine which is always under 100ms but my boyfriend has a laptop which has good fps in raids! I'll post the specs here and any help would be appreciated if possible.

This PC
Windows Vista Ultimate (6.0, Build 6000)
AMD Phenom9tm) 9500 Quad Core Processor (4 CPUs), ~ 2.2hz
4094 Ram
NVIDIA GeForce 9600 GT, 2287 mb
931gb Hard Drive of which 413gb is free.


I play at 1680x1050 resolution. And all is low on World of Warcraft. Can't play beyond Fair/Good.

Dunno if it's the graphic card slowing it down or something else. Any ways to check it?
a b U Graphics card
May 16, 2011 1:19:44 PM

more than likely the low clock rate on ur cpu is holdin you back also turning down ur resolution would help a bit.
May 16, 2011 1:40:50 PM

Oh right. So how do I do this "clocking" thing? Thanks for the reply, all those views and only one reply :( 
Related resources
a b U Graphics card
May 16, 2011 5:31:09 PM

yeah its no doubt the CPUs clock speed that is far too low, you have to learn how to OC that CPU and then get the clock speed up as much as you can ;) 
a b U Graphics card
May 17, 2011 7:16:19 PM

Your graphics card should be fine for running WoW at low settings. I have a 9800 gt (not too much better than yours) and it can run everything at max. I definitly think its the low clock speed on your CPU.

google it up!
!