Sign in with
Sign up | Sign in
Your question

No USB mice working in Vista or Ubuntu, yet USB keyboard fine

Last response: in Motherboards
Share
July 16, 2012 11:43:09 AM

I have a dual boot Windows Vista 32-bit / Ubuntu Linux 12.04 LTS PC that I built four years ago. It's never had any issues. A couple of 'days' (weekends, but it's not used during the week) ago the USB mouse started to freeze in Ubuntu, and it seemed to do so randomly rather than at high load etc. Once frozen I could unfreeze it by unplugging it and replugging it back in. The mouse also started to stick in Vista at the same time but unstuck itself after a second or so.

I started to go down the obvious routes - update drivers, check for errors in Device Manager (none). I then removed the card reader (USB direct to board) and unplugged Bamboo Fun tablet, just in case one of them had errored and was causing the problems. The motherboard ended up with just the keyboard, mouse and the integral LAN wireless card as USB components. I've since disabled the LAN card in BIOS also.

Assuming the mouse itself was damaged, I then switched to an old Wacom tablet mouse I had that has been used on the setup without issue before for years. This worked fine for a few hours in Windows, then also started to get stuck. Switching back to the optical mouse, the situation is now worse, and freezes in as well Windows and needs unplugging to get it started again. All back I/O ports are affected and the front panel ports.

Infrequently I get USB malfunction messages on the taskbar, but these are very rare - maybe once a day, whereas it's freezing even few minutes and sticking several times if you even try to move the pointer across the screen. Once the mouse refused to come out of being frozen at boot and at that point the keyboard did also freeze, although that's not happened again - after being left off and unplugged this resolved back to the constant sticking and freezing.

I updated the Intel Chipset Utility (no effect), and then updated the BIOS which included a CMOS reset (no effect). Re: CMOS/CPR - the PC is unplugged five days a week by default, though I've not removed the coin battery since the BIOS updated included a CMOS reset anyway. I've also disabled the LAN wireless card now in case that was damaged also, to no effect, so the only USB components running are the mouse and the keyboard.

The motherboard is a Asus P5K-e wifi which does have a PS/2 port for the keyboard but not for a mouse. The BIOS is now the most recent. USB is enabled in BIOS. Both mouse and keyboard are cheapo Technika ones.



The only thing that changed that I can think of was that I upgraded to Ubuntu 12.04 LTS a day or so before this started to happen. Beyond that nothing has changed, and as I say, Windows is affected as well.

As an aside the BIOS also thinks the PC has a floppy drive (it does not and never has) and it can no longer see a slave drive. The non-existant floppy drive predates the BIOS update, but I can't remember how long the slave drive has disappeared for - it may well have been missing for weeks, I don't use it. I haven't really looked into the drive confusion yet - been preoccupied with the mouse side of things. The slave IDE is attached via a card (it's an old PATA drive and the motherboard doesn't have any PATA inputs).

I've been assuming this is a hardware issue as the problem is independent of OS, but am perplexed that it's affecting all mice rather than just one dodgy mouse, but not affecting the keyboard. I've ordered a new cheapo optical mouse for the sake of trying yet another mouse. I perhaps could have confused the system by having both an optical mouse and a Bamboo tablet plugged in at the same time, but wouldn't that be OS-specific as well? If the USBs in the I/O board are fried, is it odd that the USB keyboard is working fine, and that the mice don't work in the front ports either?

I am planning to build a new PC/rebuild this one but not for another few months - ideally this one needs to limp on until November. I'm running out of ideas - I haven't tried any pen drives as I didn't have any expendable ones to test, but I can test one if it's likely to give more info. I could try a PCI Express USB card but I'm wondering if that will have similar issues. I've ordered a new USB mouse to see if a completely novel mouse has the same issue.

I'm at a bit of a loss and would appreciate any ideas!
a b V Motherboard
July 16, 2012 11:26:23 PM

There is a lot to absorb so ....
I'd rather know a bit more about your hardware like PSU, Ram, etc

If the CMOS is resetting on each boot up then the battery is flat. Your Date/Time will alwys be wrong and your system relies on correct date/time for file verification and security issues.

The floppy drive should be disabled in the BIOS boot preferences.

The mouse might just need an intelli-point update if it is generic.
http://www.microsoft.com/hardware/en-us/d/intellimouse
July 17, 2012 9:53:03 AM

Sorry - TMI ;)  You can tell I'm starting to go in circles with this.

Here's the setup:
450W PSU
500GB 7200rpm Western Digital hard drive
(Slave drive connected via PCI card in theory but no longer showing up)
Vista Home Premium 32-bit (and dual boot Ubuntu 12.04 LTS)
2GB of RAM DDR2
Intel Pentium Dual Core processor 2.5GHz
LG Lightscribe DVD-RW
1GB NVidia graphics (can't remember which card)

All updates for both OS's are downloaded, it's not particularly dusty, it's certainly not running hot (lots of fans, no speed control, chassis temp around 28C, CPU was about 38C after a few hours of use).

CMOS isn't resetting - I just meant that the PC is unplugged regularly. I read that unplugging the power is a possible solution for issues, and by default I've already done that, but I'm out of my comfort zone here so may well have misunderstood that bit! The date on the PC (in BIOS and in both OSs) is fine despite long periods of being unplugged.

The floppy drive is the 3rd boot option at the moment (below the HDD and the optical drive) but it's still showing up as a drive in BIOS (not in OS) - I didn't see a way to disable it but will look again - I wasn't looking specifically.

I will try the intelli-point update - thank you! Although if that's just Windows would it affect the mouse in Ubuntu? It'll be the weekend by the time I get back to try it so apologies for intermittent updates.
July 21, 2012 12:15:15 PM

Update - I plugged in a new optical USB mouse and a PS2 keyboard and removed the USB keyboard and old mouse, and it appears to have resolved the problem. When I plugged the old mouse back in, it failed, so that suggests it's the simple answer; the mouse was broken. Why this also meant the Wacom tablet wasn't working I'm not sure. I have since plugged the USB keyboard back in and the new mouse continues to work. Thus the old mouse is now in the bin.

Sometimes the simplest solution, eh.
!