Asus Sabertooth 990FX mouse problems bios screen

hi,just bought a Asus Sabertooth 990FX and I have this problem,when in the bios screen the mouse just don't work and I can't use keyboard either.Can anyone tell me whats here the problem?I done all the updates from Asus website!!appreciate any help,cheers
5 answers Last reply
More about asus sabertooth 990fx mouse problems bios screen
  1. This may be too late to help you. Try using a ps2 mouse and keyboard if you have'em. Also, make sure you have upgraded the bios to the very latest. They may have already fixed that issue. Good Luck!
  2. Have you tried the USB mouse with a green USB to PS/2 adapter plugged into the motherboard's PS/2 keyboard/mouse combo port?

    Are you using the two USB 2.0 ports below the PS/2 keyboard/mouse combo port for your mouse and keyboard? If not, you should be.

    In the ASUS UEFI BIOS Utility - Advanced Mode

    Advanced tab page --> USB Configuration

    Make sure Legacy USB Support is set to [Enabled]

    If you're using the USB 3.0 for the mouse and keyboard you will need to make sure the Legacy USB3.0 Support setting is set to [Enabled].
  3. Not really to late,I'm about to buy another one and just in case it happens again,and about change mouse,use ps2 and upgrade the bios already did that!thanks for the quick reply,appreciate!

    I use wireless mouse but also I try cable one and change keyboard and is the same thing!!

    I'm not sure how is the configuration on the UEFI Bios because I can't get there really.The arrow of mouse is on one corner of the screen and if you move goes back to that corner straight away,very quick and impossible to manage the mouse or keyboard!!just weird
  4. my keyboard is ps2 and wireless mouse or usb mouse, both do same thing!!cheers
  5. I was having this trouble yesterday but i found out i plugged in my mouse and keyboard in the usb 3.0 slots,i reset the pc after i plugged them into the usb 2.0 and worked fine.
Ask a new question

Read More

Motherboards Asus Sabertooth Mice BIOS