Sign in with
Sign up | Sign in
Your question
Closed

Asus p8z77-v motherboard wont power up

Last response: in Motherboards
Share
July 18, 2012 2:31:52 PM

I have a OCZ modxstream 500w psu connected to the above mobo but it won't power up .
The psu wiil start up if pin 4 is connected to earth but not when it connected the mobo even if pin 4 is
held connected to earth.Any known incompatibility between the two?
Ian
a c 121 V Motherboard
a b Ĉ ASUS
July 18, 2012 2:50:57 PM

What other hardware are you using in your build? Have you overclocked anything yet?
July 18, 2012 3:06:30 PM

2117275,2,965211 said:
What other hardware are you using in your build? Have you overclocked anything yet?[/quotemsg
Thanks for your reply.
Nothing is connected to motherboard other than the psu.
Related resources
a c 121 V Motherboard
a b Ĉ ASUS
July 18, 2012 3:22:38 PM

What do you mean by "nothing is connected"

The motherboard won't poweron without RAM and a CPU installed. Also you have to have both MB power connectors attached.
July 18, 2012 3:25:34 PM

Thanks for your reply.
Nothing is connected to motherboard other than the psu.
July 18, 2012 3:35:10 PM

itzdanielp said:
What do you mean by "nothing is connected"

The motherboard won't poweron without RAM and a CPU installed. Also you have to have both MB power connectors attached.

Sorry perhaps I used the wrong term. Should have said the PSU won't switch on. All my previous mobo's would at least turn on the psu before having the other hardware connected. I do this as preliminary check.
Perhaps this mobo is different

Best solution

a c 121 V Motherboard
a b Ĉ ASUS
July 18, 2012 4:04:04 PM
Share

Asus's are pretty sensitive, and often they won't poweron even if a component is slightly loose. I would suggest putting in a CPU and at least 1 RAM stick, and trying again.
July 20, 2012 7:21:36 AM

itzdanielp said:
Asus's are pretty sensitive, and often they won't poweron even if a component is slightly loose. I would suggest putting in a CPU and at least 1 RAM stick, and trying again.

Thanks for the suggestion. It appears that EATX mobo's do require a cpu and memory before the PSU will turn on. Your suggestion solved the problem Thanks
a c 121 V Motherboard
a b Ĉ ASUS
July 20, 2012 2:48:48 PM

Glad it worked out for you!
a c 328 V Motherboard
a b Ĉ ASUS
July 20, 2012 11:20:13 PM

Best answer selected by Nikorr.
a c 328 V Motherboard
a b Ĉ ASUS
July 20, 2012 11:20:27 PM

This topic has been closed by Nikorr
!