Sign in with
Sign up | Sign in
Your question
Closed

My pc isnt doing anything

Last response: in Motherboards
Share
July 19, 2012 7:49:52 AM

Ok so my specs are this
case:haf 912
motherboard:asrock 970 extreme 3
cpu: amd fx-8150
gpu:sapphire 7850 OC
psu:CM GX 750w
heatsik:hyper 212 plus
HDD:seagate barracuda 2tb
ram:8gb(4X2) gskill sniper 1600
please help me my pc comes on but nothing will come up on the screen.it worked fine for 3 days then after installing a windows 7 update the following day it just quit on me.when i turn it on nothing comes on the screen.i plugged the speaker that came with the case into the motherboard and i heard no beeps when i turned it on.im scared that i need a new motherboard or even worse please anyone help me :( 

More about : isnt

a b V Motherboard
July 19, 2012 8:50:29 AM

reset CMOS battery.
Score
0
July 19, 2012 9:05:06 AM

i am actually right now
Score
0
Related resources
a c 478 V Motherboard
July 19, 2012 9:10:42 AM

if your mb has video port..try unplugging the gpu with the power off. (remving the video card from the system). see if the onboard video works..you should get some fans moving if the ps is working. if there not or there twitching..could be the ps or there a screw or somthing shorting the ps out. alos try using one stick of ram to see if one stick went bad. i would see if someone has an extra power supply. the brand you have is meh...
Score
0
July 19, 2012 9:27:41 AM

1.no video port and 2.i tried the only 1 stick of ram and it did not work 3.the psu and fans are perfectly fine
Score
0
July 19, 2012 9:36:57 AM

please reply anyone im desprate
Score
0

Best solution

a c 137 V Motherboard
July 19, 2012 9:42:42 AM

It DOES sound like the mobo died, but that's extremely strange because of the way it happened.
Share
July 19, 2012 9:45:44 AM

i just dont know how it could i have a anti static wristband that i wore a lot
Score
0
a c 137 V Motherboard
July 19, 2012 9:49:09 AM

Yeah, I don't understand it either. It wouldn't have been ESD though, since it worked originally. If it was ESD, it just would never have worked. It wouldn't be a short either because of the same reason.

A Windows update shouldn't have killed it either, though. Just strange, but no POST beeps almost always means a dead mobo.
Score
0
July 19, 2012 9:50:14 AM

are you sure the the mobo died
Score
0
a c 137 V Motherboard
July 19, 2012 9:52:17 AM

devilofdeaths said:
are you sure the the mobo died


Not 100% positive, no, but it makes the most sense. If it was anything else, you should at least get an error beep at POST.
Score
0
July 19, 2012 9:57:43 AM

and theres no lights on the mobo so i cant tell if that helps or not but its like a $90 mobo could you suggest a good one for under $125
Score
0
a c 137 V Motherboard
July 19, 2012 10:00:25 AM

devilofdeaths said:
and theres no lights on the mobo so i cant tell if that helps or not but its like a $90 mobo could you suggest a good one for under $125


How new is it? I'm guessing that you just got it, so it should still be within the 30 day replacement period for most vendors. Even if it's past that, it's still has a manufacturers warranty. Just RMA it.
Score
0
July 19, 2012 10:03:04 AM

this is my first build and yes it is less than 30 days old and since this is my first build how do i RMA
Score
0
a c 137 V Motherboard
July 19, 2012 10:04:46 AM

devilofdeaths said:
this is my first build and yes it is less than 30 days old and since this is my first build how do i RMA


Just contact the vendor that you bought it from and get started that way. I'm honestly not exactly sure how it works because I've thankfully never had to RMA anything.
Score
0
July 19, 2012 10:07:51 AM

DJDeCiBeL said:
Just contact the vendor that you bought it from and get started that way. I'm honestly not exactly sure how it works because I've thankfully never had to RMA anything.

lucky but i guess i will see what i can do and if they wont take it i will get your suggested board
Score
0
July 19, 2012 10:11:55 AM

Best answer selected by devilofdeaths.
Score
0
a c 478 V Motherboard
July 19, 2012 3:57:57 PM

if you got it from new egg go into the sales of the mb there a bock to request an rma. if you got it on amazon contact the seller. if you go it from micro ceneter...just walk in with the box and mb and your sales sheet. they swap the mb right there. if not the mb vendor have under there support page a link to start the rma...most just need the serial number of the mb to start the rma. when the rma number is given you have to ship the dead board with the rma paperwork in the box and the rma number on the ups or shipping lable. (be care full putting the cpu cover back on so you dont bend any pins.)
Score
0
July 19, 2012 4:17:04 PM

actually i already have it to be picked up tomorrow but thanks anyways
Score
0
a c 328 V Motherboard
July 20, 2012 8:38:31 AM

This topic has been closed by Nikorr
Score
0
!