Sign in with
Sign up | Sign in
Your question
Closed

IS MY VIDEO CARD FAILING?

Tags:
  • Graphics Cards
  • Crysis
  • Graphics
Last response: in Graphics & Displays
Share
May 19, 2011 7:38:55 PM

I just built my rig a few weeks ago it has been running great. Well last night while I was play BFBC2 I started to get black blotches on the screen when I would over look the map with my scope. And crysis 2 today freezes up on me every now and then. This never happened before. What could this be thank you.

More about : video card failing

a c 153 U Graphics card
May 19, 2011 7:53:55 PM

What drivers did you install? What kind of heat are you getting on that stock cooler on your CPU? I would have gotten a much cheaper but good quality PSU around the 750w range, but thats just me. Yours is fine, just doesn't really make sense for the build, even if you had SLI 560ti that is still way overkill.
Score
0
May 19, 2011 8:04:52 PM

Its the newest drivers for everything. Im getting between 51 and 52c on my cpu with stock cooler at full load. I was going to get the 750w but they were out of stock in the one i wanted and i am going to run sli and yes its overkill i know lol. but i am worried about the video card i tried to overclock it and it wasnt stable so i stopped. Could i have hurt it i didnt overclock it for very long at all.
Score
0
Related resources
a c 153 U Graphics card
May 19, 2011 8:16:11 PM

Newest drivers? According to Microsoft, EVGA, or Nvidia?

No you didn't hurt the video card, but I'd reset it to stock. What did you use to overclock it?
Score
0
a c 124 U Graphics card
May 19, 2011 8:35:08 PM

Sounds like it might be artifacting. If temps are ok and it's at default speeds/voltages then it might indeed need to be RMAd.

Definitely worth trying a driver reinstallation though. Make sure to uninstall and Driver Sweeper all the old drivers before you install the newest ones straight from Nvidia's website.
Score
0
May 19, 2011 11:02:57 PM

I have the newest Nvidia drivers, i think that my problem may have been from installing the newer driver that was a beta. I used msi afterburner to overclock it. So do you think that it needs to be returned? And thanks guys
Score
0
May 19, 2011 11:19:37 PM

Okay.

1. Clean out and reinstall drivers.
2. Don't overclock anything. Go back top stock settings.
3. Does it happen in other games?
4. BFBC2 does not like MSI Afterburner (read the readme notes when you install Afterburner). Other games that use Punkbuster or overlays can also have problems with Afterburner. If you are running Afterburner in the b.g. while playing BFBC2 Multiplayer on a Punkbuster server it will crash eventually. This is a well known issue.
5. You will not be able to run SLI on your motherboard. It is not SLI compatible.
Score
0
May 20, 2011 12:10:58 AM

I know I have to upgrade my motherboard to run sli i messed up bad on that one. I havnt notice anything in other games other than crysis 2 was freezing but that has stopped. Would you recommend putting a aftermarket cooler on the card such as the artic? And dragon age 2 was failing forgot about that but i heard that it has been running bad with nvidia.
Score
0

Best solution

May 20, 2011 12:13:55 AM

If it's only happening in one game then it's probably not a hardware issue with the card.
Share
May 20, 2011 1:31:51 AM

Best answer selected by jtgolden1s.
Score
0
May 20, 2011 1:32:01 AM

chriskrum said:
If it's only happening in one game then it's probably not a hardware issue with the card.

Thank You
Score
0
a c 124 U Graphics card
May 20, 2011 5:08:15 AM

jtgolden1s said:
I have the newest Nvidia drivers, i think that my problem may have been from installing the newer driver that was a beta. I used msi afterburner to overclock it. So do you think that it needs to be returned? And thanks guys


Was it overclocked when it was failing? That probably means a bad overclock not a bad card. Only if it happens at stock is there a possibility of an issue with the hardware.
Score
0
May 20, 2011 5:34:15 AM

Yeah it was overclocked and then I set it back to stock and it kept doing it. When i took off the new beta drivers it stopped doing it so I guess it was the drivers.
Score
0
a c 274 U Graphics card
May 29, 2011 9:34:07 AM

This topic has been closed by Mousemonkey
Score
0
!