Sign in with
Sign up | Sign in
Your question

*Help* BIOS and POST problems with XFX 6850.

Last response: in Graphics & Displays
Share
May 21, 2011 3:28:59 PM

Just replaced my GTX 460 with a Radeon 6850 (due to some testing reasons that I won't go into here). When I booted up the 6850 the first thing I noticed was missing type on the POST screen under the American Megatrends logo. I was able to get into Windows and everything ran fine. However, when I tried to get into the BIOS setup screen it just froze. I did a CMOS reset and tried that only to see video garbage on the screen and no joy on BIOS setup or boot.

I called XFX and they told me that they thought the card was probably bad. So, I RMA'd it and NewEgg shipped me a replacement overnight. I installed the replacement card and have seen the exact same symptoms. Have tried everything (unplugging all the drives, single stick of RAM with 2 different ones, a different PCI-E slot on the motherboard, flashing the BIOS with the latest version, etc). No luck.

If I plug the GTX 460 back in all is fine.

Here are my details. Any ideas? So far this is a complete mystery.

Details:
Corsair 650TX
Asus P8P67 PRO B3 (currently using default BIOS/UEFI settings)
XFX Radeon 6850 (dual fan, single 6-pin power connector)
i7-2600k
Ripjaws 8GB
Antec 300 case




May 21, 2011 6:37:06 PM

Update: Asus tells me Northbridge on motherboard could be bad? Any ideas?
m
0
l
a b U Graphics card
May 21, 2011 6:46:18 PM

How did they arrive at the possibility of NB being bad??

If the NB was bad, why would the 460 work fine?


Are you trying to run a ATI card without uninstalling your Nvidia drivers?
m
0
l
Related resources
May 22, 2011 4:55:19 AM

I don't think drivers would play into it since it's the post/bios settings screen, not the actual OS? I'm not sure how they've arrived at that conclusion. I think their logic is probably something as complex as:

1. customer desc
ribing garbage video and other symptoms on bios screens?
2. card bad
3. 2nd card tried?
4. northbridge bad.

Is it possible that this could be caused by being plugged into an odd dimension display (720p)?

m
0
l
May 22, 2011 3:27:54 PM

Yes, that's my posting. ;-) I'm hoping others with a similar config can test this.
m
0
l
a b U Graphics card
May 22, 2011 3:39:19 PM

LOL, sorry I didn't check the name of the poster.

Did you see what the other guy suggested?
m
0
l
May 22, 2011 4:27:31 PM

Yeah, somehow he seems to be talking about having 2 different displays connected to the same card. It's becoming clear that this some kind of incompatibility between UEFI graphics modes and the Radeon chipset when using an HDMI display.
m
0
l
a b U Graphics card
May 22, 2011 9:10:54 PM

Very strange that it works fine except in the bios.

I have a 5850 hooked to my monitor via HDMI and I have no issues in my UEFI bios.
m
0
l
May 22, 2011 9:31:56 PM

I think it has to do with resolution. Others that have discussed this are connected to 720p or 1080p TV/projector displays via HDMI.
m
0
l
a b U Graphics card
May 22, 2011 9:44:42 PM

It's a 22" 1080p HDTV, looked fine in bios
m
0
l
May 22, 2011 10:13:36 PM

Maybe because my projector is 720p/1080i? Type of HDMI (the projector has a very early HDMI connection)? I really need to get it plugged into another display...
m
0
l
a c 171 U Graphics card
May 23, 2011 3:30:11 AM

motherboard bios update.
m
0
l
May 23, 2011 4:03:50 AM

iam2thecrowe: tried it. got the latest and it didn't help. actually just tried an XFX 5770 and same problem. connected to VGA port via DVI->VGA connector and I am now able to pull up the settings and see the POST report. This is definitely in need of an update. Obviously somebody isn't testing.
m
0
l
May 23, 2011 4:07:59 AM

But yes, Asus needs to release one. This is ridiculous.
m
0
l
June 7, 2011 1:47:46 PM

Josh,

I am having the same issue. I've recently built a new rig: Asus Sabertooth P67 Mobo, Core i7 2600K, Corsair AX750 PSU, 16 GB Corsair Vengeance 1600 RAM, XFX 6870 (single) video card. I am running an Acer 22" LCD monitor (DVI) and a Toshiba 42" 720p HDTV via HDMI. Like you when I boot (POST) everything on my monitor is quite large, and when I enter EFI I am unable to view the entire screen. Of course this does not happen when I disconnect the HDMI cable---everything during POST and EFI returns to normal. I have yet to try some of the suggestions in many of the forums that I have read, but like you, do believe that there is something going on with my ASUS board. I have tried tweaking the settings in CCC, but have obviously had no success. I DO have a DVI>HDMI cable and will try that as a short term fix, but I bought the card because I wanted to utilize the full HDMI connector on the board and am not satisfied. This issue is really only the most recent issue that I have been experiencing and so far, I am deeply disappointed in both the ASUS product and their failure to properly support it.

Please let me know how you are progressing with trying to find an answer with this issue.
m
0
l
June 7, 2011 2:11:07 PM

Hi. I've had no success except for going via DVI with an adapter to the VGA port on the projector. Asus actually wrote me back and replied that the UEFI only supports 1024x768 and XFX said they would test for the issue but probably wouldn't do much unless it's clear that others are experiencing it.

Therefore, I think if the display doesn't support native 1024x768 and the video card can't emulate it somehow (as with the Radeon) then the motherboard appears to essentially freak out. I have not experienced the issue using the NVidia card so it's definitely some kind of interaction and if I had to place the blame I'd actually put most of it on the Radeon card at this point. On the other hand, I haven't heard of it on anything but Asus or Asrock boards (Asrock being a subsidy of Asus, yes?).

I would suggest emailing Asus and posting on various forums. Also use XFX's support page to create a ticket.

m
0
l
August 11, 2011 12:00:51 PM

Maybe same issues when it comes to P8P67 and HD 6000 series video cards. The EFI BIOS does not display correctly in a HDMI monitor, you can only see it in a VGA monitor. YES IT SUCKS! we did not buy those good video card for VGA monitor. I already mail ASUS, no reply yet. If you have time try mail same concern to them.
m
0
l
August 18, 2011 2:37:58 AM

A rep from Asus themselves confirmed the issue. It is known that there is a problem but there is no fix (except using VGA when you want to use specific displays that have certain kinds of refresh/resolution via HDMI).
m
0
l
!