Sign in with
Sign up | Sign in
Your question

HD 6850 Flickering, help PLEASE !!!!!

Last response: in Graphics & Displays
Share
May 22, 2011 12:15:00 PM

hi guys, i m experiencing some texture flickering (some shadow flickering too) in all games like: GTA4, GTA EFLC, Medal Of Honor(2010), Dirt2, AC Brotherhood, etc

My System Specs are as follows:

AMD PhenomII X3 720BE (oc'd 3.5ghz at 1.43v vcore)
MSI 790GX-G65
2X2GB DDR3 Corsair XMS3 1333MHz CLK9 RAM
Sapphire HD 6850 1GB
Cooler Master RS500 extreme psu

Temps are fine (idle: 40`C load: 72`C). Problem started after 4 months of purchase.
Even Voltages are fine (used everest ultimate v5.50):
+12v = 12.24
+5v = 5.02
+3.3v= 3.34

Some things which i think colud be causing the problem:
1. My cabinet gives me shock even tough my house is earthed
2. to run my RAM stable at stock Frequency i hv to run it on 1.67-1.71v as advised by corsair's Tech. Support (cause my sys. Freezes on 1.5v)
but tough these persisted when i purchased the card and it ran fine for 3 months i doubt it could be somthing else which is causing problem

pls help guys !
EVERY REPLY WILL BE APPRECIATED
THANKS IN ADVANCE !!!!!!

More about : 6850 flickering

May 23, 2011 5:11:26 AM

if your pc is shocking you then something isnt mounted properly. That could also be causing your ram issue and video card issues. Take it apart and check all the screws and standoffs to make sure that nothing is touching the motherboard back plane.
m
0
l
May 23, 2011 9:31:05 AM

could be a ram issue, just make sure your vid card drivers are updated. you may also want to play around with CCC settings, try different catalyst AI settings, and different anisotropic and trilinear filtering settings. turn optimisations off.
m
0
l
Related resources
May 23, 2011 6:41:32 PM

shin0bi272 said:
if your pc is shocking you then something isnt mounted properly. That could also be causing your ram issue and video card issues. Take it apart and check all the screws and standoffs to make sure that nothing is touching the motherboard back plane.


thnks for reply i did disassembly and reassembled and i asure u tht nothing is in contact as far as i think. should i insulate my case plate over which we mount mobo

as per me i doubt my mobo (last year i got a replacement form MSI but they didn't replaced it with new one, the one they gave me was repaired at Taiwan according to them, and i have 2 run my ram like that since then)
m
0
l
May 23, 2011 6:47:32 PM

Try changing the power cable that your video card uses to feed herself.

Also, like pointed out, might want to try and check the "spread spectrum" configuration on your MoBo... Activate them. Last time I checked, those served as correction modes for when you have unstable voltage; could be wrong though :p 

Cheers!
m
0
l
May 23, 2011 7:11:56 PM

iam2thecrowe said:
could be a ram issue, just make sure your vid card drivers are updated. you may also want to play around with CCC settings, try different catalyst AI settings, and different anisotropic and trilinear filtering settings. turn optimisations off.


mate, i m confused over wht drivers to instal since the problem is occuring i have downgraded from ccc v11.5 to v10.10 (included with my card)
and A.I settings dosent help !

one thing i must tell u is that in ccc's 3D settings there is no option to dissable:
1. Anti Aliasing Mode
2. Catalyst A.I
u can adjust them 2 either min. or max.
"surface optimization" could be dissabled under Catalyst A.I. Also adjustment of these 2 dosent help.
Rest of the settings are set to "Application Control"
m
0
l
May 24, 2011 9:33:29 AM

Yuka said:
Try changing the power cable that your video card uses to feed herself.

Also, like pointed out, might want to try and check the "spread spectrum" configuration on your MoBo... Activate them. Last time I checked, those served as correction modes for when you have unstable voltage; could be wrong though :p 

Cheers!


ty for replying
i checked my mobo's spread spectrum it is already enabled
on thing i noticed in my cell menu was that "auto slow down ram and pci freq. = enabled (by default)" i dissabled it.
and no improvements :'( 
m
0
l
!