Sign-in / Sign-up
Your question

Pci card not recognised

Tags:
  • Sound Cards
  • PCI
  • Computers
  • Components
Last response: in Components
October 26, 2011 11:43:28 AM

after my xonar dg stopped being recognized by my computer, i rma'd it thinking the card was broken, i have now got the new one back but it is exactly the same, windows keeps acting like there is no sound card installed, even after i disable the onboard sound, any advice?

More about : pci card recognised

October 26, 2011 11:49:39 AM

it is now recognising it but under device manager it says this

Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)
October 26, 2011 12:09:31 PM

drivers are probably corrupt, uninstall the currentt drivers then download the latest ones and install.
Related resources
October 26, 2011 12:12:23 PM

hairystuff said:
drivers are probably corrupt, uninstall the currentt drivers then download the latest ones and install.

ive tried that ive used two of the asus versions and a uni driver that i was using before it stopped working
October 26, 2011 12:16:27 PM

also what are the nvidia high definition audio drivers,
October 26, 2011 12:43:18 PM

fixed it i have to disable driver signatures at every boot with f8
October 26, 2011 3:13:31 PM

^^ SHouldn't be happening, there is no reason why the drivers shouldn't be signed. Something else has gone wrong somewhere...Using F8 is a bad idea, as it basically kills all the security the OS has.

Totally uninstall the drivers, use driver sweeper to make sure all traces are gone, and re-install again. Also, try the Xonar Unified drivers and see if that helps.
October 26, 2011 4:06:07 PM

done all that still says drivers have no signature
October 26, 2011 4:13:51 PM

we1shcake said:
done all that still says drivers have no signature

Doesn't matter all that means is MS hasn't tested/certified the drivers.WHQL.
Been using my Auzentech Forte like that for over 2yrs.
If Asus does have WHQL drivers that's different you want those.
You'll want to disable the gpu audio drivers in device manager.
Desktop volume icon
select default audio playback device
Asus
October 26, 2011 4:41:11 PM

i dont care if the drivers arent WHQL, but having to press f8 every single time my computer boots up is a bit annoying, also i cant get the uni drivers to install now so ive gone back to the asus ones
October 26, 2011 4:48:34 PM

im tempted just to buy an ssd and do a blank install, ive no idea why it suddenly stopped working like, this, the only thing ive bought recently is a graphics card but i dont see how this could be affected that was 2 weeks before aswell
October 26, 2011 5:33:45 PM

^^ Only thing I can think of is the GPU Audio drivers somehow screwed up the ASUS drivers, which shouldn't be a problem because I have both the latest NVIDIA audio driver and latest ASUS Audio driver installed together without issue.

Also, this is NOT a WHQL issue. WHQL simply means teh drivers aren't windows certified, but the drivers are still digitally signed. [Otherwise you wouldn't be able to run NVIDIA/AMD beta drivers]. And theres no way the ASUS drivers aren't signed, thats a fact.
October 27, 2011 7:08:00 PM

its really annoying, if anyone ever finds a fix please tell me :( 
October 27, 2011 7:42:15 PM

Try rmoving the NVIDIA audio drivers. Shouldn't matter, but its worth a shot.