Memory expansion made my system really slow

Hi Everyone

I have just increased my system memory from 2GB to 4GB and my system is now rally slow when I use a web browser.

Completing this form has taken an age asit takes a few seconds for each keystroke to appear.

Something is clearly wrong but I don't know what. Any ideas?

As per the motherboard instructions I have 4 identical 1GB modules installed.

I'm running Windows 7 - 64 bit on an Asrock AM2NF3-VSTA with an Athlon 64 X2 CPU.

Thanks for the help.

Rob
8 answers Last reply
More about memory expansion made system slow
  1. Slow CPU, but still is OK for the web browsing.

    I think u have a virus or other pest in your PC.
  2. This will speed up your PC like u've never seen before.

    Best part for u to upgrade! 100% guaranteed.

    OCZ Agility 2

    http://www.newegg.com/Product/Product.aspx?Item=N82E16820227542
  3. Thnks for the message. I have chcked the system and I don't have either. In actual fact the system seems to work fine, the problem is just that the webbrowsers are slow. So completing this form takes an age for key- strokes to show but I can open other porgrammes like Word and type really easily. Very odd!
  4. Hi there,

    How did u check the system?

    Not add at all, if infected.
  5. BTW, u are not using the internet explorer, are u?
  6. I alas have to use IE as my work email uses Outlook with an Exchange server, and it only works properly on IE. That said whenever I use Chrome or Firefox I encounter the same issues so it seems to be a general web browser issue rather than something limited to IE.

    Still very puzzling and I haven't been able to find a solution.
  7. PS
    I checked the system using my work supplied anti-virus software package - Sophos - and also again using Ad-Aware to check for Malware etc. Neithe found anything of note.
Ask a new question

Read More

Memory Web Browser