Sign in with
Sign up | Sign in
Your question

Unusual OS Installation Failure - Need Advice

Tags:
Last response: in Windows 95/98/ME
Share
Anonymous
December 19, 2000 1:31:06 AM

Help Me Discover What Ails The HP Omnibook XE2 DC Notebook


I imagine a preface is in order.. Whenever I configure a new DOS/Windows computer I always partition the HD with FDISK (FAT32) then FORMAT. I created C:\D:\E:\F:\G: (3GB, 560MB, 5GB, 5GB, 6GB) - (system drive 3GB, dedicated virtual memory drive = 560MB). The Win98se source files were on E: - My usual technique is to boot from DOS floppy with minimal drivers on it. Then launch the Setup.exe in the WIN98 directory.

The last hundred times I did this with other computers the OS installs rather uneventfully and is followed by a dull hour or so of installing current drivers and tweaking settings for performance. Then I create a disk image follwed by installing the applications/programs.

This time was very different..

During the Win98se install, at about the time that Win98se installer looks at the hardware config, the notebook crashed - three times by the end of the install (all fatal exception errors accompanied by the dreaded blue-screen). I couldnt believe it, I've never seen anything like it so early in the progression of an OS install. I re-formatted and started from scratch a couple times, nothing made a difference, so I figured a rare instance of hardware failure, ran some tests and everything was fine - The notebook passed all of the Hardware diagnostics, including the RAM error tests. I then thought the BIOS was suspect, so I updated it to the latest version, released just a month ago. The CMOS is minimally configurable, like most portable CMOS's.
All of the most current drivers were then installed.

Now, mind you, I know a thing or two about computers, I could probably build a computer from raw silicon, hell, I might even be able to pull it off using silica in a pinch.. But I've never come across a problem like this. Usually the confilicts happen later in the game, when there is something to conflict with. Hence, my being suspect of hardware failure. BUT for the most part, the thing runs fine in Win98se 'Safe-Mode', which would be consistent of software being the culprit.

Here's what I've done so far:

- Set the CMOS to default settings (which were all reasonable)
- Clean-booted, defeating system.ini, win.ini, config.sys, autoexec.bat, startup folder files
- Run System File Checker
- Run Windows Registry Checker
- Checked for existence of a 'Winstart.bat' file - it does not exist.
- Did another Win98se install into a clean folder using what switches I could remember to keep the installer from looking for hardware.
- Troubleshot protected-mode driver problems, using msconfig's advanced settings.
- I even tried disabling EVERY device in the device manager.
- I ran the Automatic Skip Driver Agent (asd.exe)
- I checked for damaged VxDs by booting and using the 'step-by-step' function and not loading any file that had a .vxd extension.
- I checked my BOOTLOG.TXT file and confirmed I only had the usual failures (ndis2sup.vxd, SDVXD & VPD failing their initializations.
- And who could resist disabling the PCI bus IRQ steering, just to see if it might help..

And guess what? I can proudly say that I now enjoy a well-balanced mix of not only garden-variety exceptions but also fatal exceptions -- all sprinkled generously with frequent windows protection failures at bootup and/or shutdown. Oh yes, I lest I forget to mention the good-ol "Invalid VxD Dynamic Link Call" - which makes a cameo appearance on occasion.

And I mean a lot of them, I can barely boot and launch a program without an exception and every other boot-up I have to hit the reset button because a protection error froze things.

With the evidence of a reasonably-stable system when in 'Safe-Mode', I have to think my problems are not hardware. Maybe a poorly-written CMOS/BIOS.. ?

Help!

========================================================================================================================

Here are some of the more frequent error messages, I am sure most of you are quite familiar with them:


'Exception 0E has occured at 0028:C0059471 in VXD --- Called from 0028:C004B707 in VXD ---'

'A fatal exception 06 has occured at F000:0000494E'

'Invalid VXD dynamic link call from VWIN32(01) + 000714 ti device "0009", service 1'

'Your windows configuration is invalid, run windows setup program again to correct this problem'

'The size of system.dat is being misreported'

'While initializing device IOS: windows protection error'

'While initializing device CONFIGMG: windows protection error'

'The program has received an illegal operation and will be shut down'

'Explorer caused an exception C14EA650H in module MSVCRT.DLL'

'There was an internal error, you must restart your computer'


==> As my brand-new computer is currently useless to me, I will very much appreciate _any_ ideas on this, Thanks!!
Anonymous
December 20, 2000 9:45:31 AM

Well Morse it looks like you have covered all bases,I had a tech friend who had a similar prob with a new hdd, couldent get win to load or run at all, checked everything, got 3 other tech to look at it, ended up dumping the hdd and getting another, Maybe it is as Bruce Springsteen said, "Sometimes theres just a meaness in this world"
December 20, 2000 1:44:05 PM

as it does appear to be a software problem, the only possibility I see is to install a different OS.
I wouldn't try WinME, as it crashes on about half the machines I've seen running it.
Maybe Windows 2000 will work, or at least give you some more informative error messages.
Related resources
Anonymous
December 20, 2000 2:28:47 PM

Well you've sure been thorough. Just a few notes -

On the HP download page separate bios's are listed for win98/2k and winME. The winME one is dated 11/15/00(1 month ago), while the win98/2k one is dated 10/04/00(2 months ago) Please ensure you have the correct one.

Try disabling DMA on your disk drives. (although if you've already selectd compatibility mode disk access in msconfig then this isn't your problem.)

You didn't note what switches you actually used. Try using "setup /p I " if you haven't already.

Have you run a virus scanner on the computer. (I know it's unlikely - but not impossible.)
December 21, 2000 4:36:41 PM

Well I'm definately no pro (although i install about once a week lately). How about your CD being corrupt? had that prob last weekend. borrowed a freinds and finally installed (although it still did not ask for a prior version of Windows as it ussually does --- hhmmmmm)

<b> Fragg at will!!! </b>
December 27, 2000 2:58:21 PM

I had this problem once. I was at wits end until I tried this. I took the laptop HDD out of the machine and installed it in a desktop machine ( adapter needed here..cost about 10 bucks) I reformatted and scandisked the drive in windows. I then made the drive bootable ( had to remove the other harddrive) and installed windowsME from the desktop. Once I had the drive fully functional in the desktop and was satisfied it was not the drive itself I proceeded to boot to safe mode and in device manager removed most of the drivers. Then I re-installed the HDD to the laptop and let windows find all new hardware ( btw win me is better at this it copies all the .cab files to the hdd)

A little bit of knowledge is a dangerous thing!
!