Sign in with
Sign up | Sign in
Your question

WD My Book World Edition

Last response: in Networking
Share
September 27, 2010 8:13:41 PM

My Parent had their house rebuilt and it has Sonos music systems in most of the rooms and a WD My Book World Edition NAS 1tb drive. And I have used it to copy music to fine and fast, and as it is DLNA certified i can put my films on there and browse and watch from my PS3, however the data transfer rate is for films, incredibly slow, 300kb (kilobytes) per seconds. so to transfer some of my 45 gb of films it is estimating 131 hours, as in 5.5 days!

But the funny thing is I transferred the fist 20 gb of my films onto the drive in under 1 hour. An I am guessing that it is copying to the drive at the drives idle speed, not the full 5400/7200rpm or what ever it is.

I have tried to make it spin up before using it, by reading music or turning it on and off again. I have read in the maunal that you can just plug the ethernet straight into the computer (i have a macbook pro) and do it that way; it is just i don't want to upset any of the network settings and make it un able to be read by the sonos system.

Any Help is going to be a god send!

C Cowan

More about : book world edition

September 27, 2010 9:00:15 PM

I don't know of any standard hard drives that have variables speeds. They're either spun down and can't be addressed, or spun up to full speed and addressable.

Regarding performance, you said it's reporting 131 hrs to transfer the whole 45GB of data, yet you just transferred the first 20GB (almost half) in one hour. So presumably it will be finished in a little over two hours. So what's the issue?

And yes, since it has an ethernet port, you could plug it directly into a computer, although it would probably be much easier to just plug it into their router. I had assumed that’s what you did, but then thought perhaps no, maybe you’re using the USB interface for some reason. Truth is, I’m not sure, you didn’t make that very clear. It would help as well to know if the router (like the NAS) is Gigabit capable.

September 27, 2010 9:16:14 PM

Well, I had copied a different 20 gb, and then it went really slow and I gave up and cancelled it and have retried several times to this really slow rate of 300kb/s and it will take far too long to do it (a week of having m laptop on copying and i take my laptop all over london with me). And yes it is plugged in to a ethernet socket, there is a 32 way netgear ethernet switch board thing to the router and the Sonos system is wired.

So the real question is why can't a get a respectable transfer rate?

Thanks for you're help

C Cowan
Related resources
September 28, 2010 2:30:08 AM

I found the following review ( http://reviews.cnet.com/hard-drives/western-digital-my-... ):

1.5 stars "Easy to setup, poor performance"
by jkhouw on 2009-12-10 19:09:18.0
Pros: Easy to setup, no software to install, cheap.

Cons: poor performance, slow administration pages, unable to handle large files.

Summary: While it is easy to setup, I had purchased this to store media files (large video files>1gb per file). Apparently (and western digital KNOWS this) the drive frequently freezes or locks up requiring a power cycle when transfering either more than 10,000 files OR files larger than 500MB at one time. Since almost all my files are more than 500MB, this basically makes this drive useless. Save your money, buy something else.

Now granted, this is just one review. But the review seems to suggest that others have reported likewise. Let’s say it is true. Then the behavior you’re seeing might be explainable. Maybe it works fine for a while and then “freezes” (using his language). Windows might not know there’s a problem and keeps waiting. As it waits, the current speed as reported by Windows eventually begins to fall. It’s continually calculating the transfer speed based on data transferred so far divided by the elapsed time, then estimating the time left based on that speed and the amount of data left to transfer. So that could explain the brisk start followed by the precipitous drop when it eventually fails.

Again, this is just one reviewer. But I did find it interesting. Anytime you’re dealing w/ a closed system, it’s always possible there is a bug, and it might not be immediately apparent. It might take an exceptional operation (e.g., transferring 45GB of data all at once) to trigger it. I wonder if you can even get into the NAS’s UI when this happens. Maybe it’s frozen completely and needs to be rebooted!

September 28, 2010 7:18:09 AM

Well there is WD software, but we (me and my parents) weren't given a copy of it either and it isn't for mac (like me) and knowing WD software it will be fairly rubbish as it is.

Many thanks for your help, I will try and just plug it in over ethernet and copy it that way.

regards

C Cowan
September 28, 2010 12:11:37 PM

The reviewer isn't referring to client software, or any software that might have come on CD. He’s suggesting the firmware that controls the NAS (i.e., code embedded in the NAS itself) has some known issues w/ large files. If true, the only thing that could fix it is a firmware update from WD.
September 29, 2010 12:48:28 PM

Well I just plugged my MacBook pro into the ethernet switchboard thingy and it worked a dream. Did it in about 40 mins. Amazing! Now to test the dlna on my ps3.

Many thanks again

Regards

C Cowan.
!