Sign in with
Sign up | Sign in
Your question
Solved

Help with internet/router

Last response: in Networking
Share
September 29, 2010 1:16:46 AM

Hello,
My roommates and I have been having some internet troubles lately and before I contact Comcast to have them come out and check it out. I want to do everything in my power to try to fix it. Myself and another roommates use a line connection to the computers whereas the other two roommates depend on the wireless. I'm not sure if the problem may be with my roommates torrenting during the day.

When I run tests on http://www.pingtest.net/ and http://speedtest.pavlovmedia.net/ I can get up to 20 Mbps Down and 10 Up on occasion. On the other end of the spectrum we can have absolutely horrible download and upload speeds and webpages will timeout. We also will have packet loss on occasion, accompanied with terrible latency (300+)

I have used the TCP optimizer from http://www.speedguide.net/downloads.php on mine and my roommates computers. I feel like it has sped up the internet when it is during an uptime, but has not helped in the long run.

Our router is my roommates netgear wnr2000 and the modem is a motorola surfboard sb5101u rented from Comcast.

Today when the internet slowed down I disconnected my computer from the router and connected directly to the modem and it seemed to fix the problem. I'm not sure if the router or computer settings can be changed to decrease the latency. Also, if I can change my roommates utorrent programs' settings to not "hog" so much internet that might also help.

Any help is appreciated, and if more information is needed, I am more than willing to do so.

Edit: Also, if I posted in the wrong section I apologize I wasn't sure where to post so I figured general discussion.

More about : internet router

Best solution

September 29, 2010 2:00:22 AM

Is QOS (quality of service) enabled on the router?
yeah if all of the computers are downloading stuff, they might be taking up all of the bandwidth leaving the rest with barely any thing to use. I would see if Enabling QOS helps, and limate everyone by like 1 Mbps or something to see if that fixes the problem.
Share
September 29, 2010 6:16:51 AM

Hi, I will give you some advice.
The first way is to depend on Ethernet cable.
1. Disconnect the Ethernet cable from your computer and plug into the WAN port in your router. Get another Ethernet cable and connect a LAN port of the router to your computer (to the port you disconnected the first cable). Run the configuration software for the router and make sure you protect the wireless connections (encryption) for security reasons.

2. Contact an Internet service provider (ISP) and have them configure an Internet connection to your home. If possible, have the ISP place the modem in the room with your primary computer.
Connect your router to your modem in one of the two following ways:
If you currently have a computer connected directly to your modem: Unplug the network cable from the back of your computer, and plug it into the port labeled Internet, WAN, or WLAN on the back of your router.
Connect the network cable to your computer's network adapter. Connect the other end of the network cable to your network equipment.

The second way is to depend on the wireless.
The issue is usually caused by one of two things: the driver for your wireless card or the firmware version on your router (basically the driver for the router). I have found that unless you’re using a really old wireless router, it’s more than likely an old driver for your wireless card that is the culprit. So you have to update the wireless card. How do we do that?
1. Download latest drivers. Here I’ve tried to get the direct links to those pages for the most common computers:
2. Select your system or type it in and find the latest driver for you wireless card. There is usually a section called Networking and underneath you should see a list of drivers.
3. You can determine the model number for your wireless card by pressing the Windows key + the Pause button at the same time. This brings up the System Properties dialog. Another way to get to it is to right click on My Computer and select Properties. Once there, click on the Hardware tab.
4. You’ll see a list of devices with plus signs to the left of them. Click on the one called “Network Adapters” and there will be an entry for your wireless card as shown below:
Now download that driver from the list off the manufacture’s web site. Usually the wireless card is called something “Intel Pro Wireless” .Once you download the file to your desktop, double click on it and follow the steps to install. You might have to restart your computer.
5. Now you should find that the number of times the connection drops or disconnects is very low. Once I updated my driver, I haven’t disconnected once!
m
0
l
Related resources
September 30, 2010 2:35:22 AM

Catsrules said:
Is QOS (quality of service) enabled on the router?
yeah if all of the computers are downloading stuff, they might be taking up all of the bandwidth leaving the rest with barely any thing to use. I would see if Enabling QOS helps, and limate everyone by like 1 Mbps or something to see if that fixes the problem.


Thanks for the help, QoS was activated, and for some reason my mac address was set to a low priority so I changed it to high, and earlier today I set the bandwith to 1 Mbps. I changed it while the internet was slowing down and it seemed to even it out. My roommate was in a game getting 200+ latency and after I switched it, it kicked him from the game but when he relogged he was at a perfectly acceptable latency. I'm hoping this fixed the problem, but if it continues to act up I will post again. I also ran speed tests before and after, and their was a drastic difference.
m
0
l
October 4, 2010 5:52:29 AM

Hey ShiftyHobbit in addition to QoS also make sure you've got the latest firmware updates for the router.
Do you have WNR2000 or WNR2000v2 ?
If it is WNR2000 a.k.a WNR2000v1 here's the link to latest firmware
WNR2000 Firmware Version 1.2.3.7

These are fixes mentioned on their page.
Quote:
Known Issues

* Fixed: NAT hairpinning issue
* Fixed: eMule running on LAN PC gets low ID
* Fixed: Static route can not work if the destination IP/subnet are on the LAN side.


Hope this helps too

Regards
KingArcher
m
0
l
October 5, 2010 2:08:13 AM

KingArcher said:

Do you have WNR2000 or WNR2000v2 ?


It says WNR2000v2 on the router page. I checked with the updater to make sure there was not an update.
Thanks for the response!
m
0
l
October 7, 2010 12:53:50 AM

I'm having a new problem now, last night and today the internet is goes really slow to the point where pages are timing our. I powercycle the modem and router and its ok for another 5 minutes then gets slow. I plugged directly into the modem and the problem didn't occur again. I'm beginning to get completely stumped. I changed the ethernet cord from the modem to the router. I honestly don't know what else to do.

edit: Last night when it slowed down I switched it to a linksys router and today when it started messing up again I switched it back to the netgear and it went back to normal
m
0
l
October 7, 2010 4:19:20 AM

Give it up. Just get a software firewall and AV protection from a firm like F-Secure. The router is bunk.
m
0
l
October 14, 2010 4:36:54 PM

I think for the most part it has been getting better. I have been getting good speeds all week, but today and yesterday when I try watching hulu the internet freezes up and I have to powercycle the modem and router. It seems fine again for another 10 minutes, but disconnects again.

Edit: On Hulu's support section it suggests running a trace route to hulu:

Perform a traceroute. If you receive an output with 13 or more hops, the problem is most likely related to how your Internet Service Provider is routing your computer's requests to Hulu. Unfortunately, Hulu is unable to fix this problem - you can try contacting your Internet Service Provider to request help.

I did this and came up with 13 lines. Is this something that I need to contact Comcast about?
m
0
l
Anonymous
November 1, 2010 12:35:40 PM

Best answer selected by fihart.
m
0
l
!