Sign in with
Sign up | Sign in
Your question

XFX HD 5770 + Starcraft 2 really bad lag!

Last response: in Graphics & Displays
Share
May 26, 2011 10:08:36 AM

Hey guys, my rig is;
AMD Phenom II X4 955 3.2ghz
asrock 880g Mobo
XFX HD 5770 Graphics
Corsair 4x2gb 1333 DDR3
Win7 64bit
my graphics drivers updated 2 days ago.

im running starcraft 1920x1080 medium settings, and still getting major lag.
my internet connection is fine, its a graphic/system lag :S
a c 1362 U Graphics card
May 26, 2011 10:46:52 AM

Did it start when you updated the drivers? If so roll back the drivers to the previous version.
m
0
l
a c 153 U Graphics card
May 26, 2011 11:03:01 AM

Added on to what Rolli said SCII seems to favor Nvidia cards somewhat. What settings are you using, I know you said medium, but what about AA and what not.
m
0
l
Related resources
May 26, 2011 11:14:07 PM

Im at work at the moment so cant check for specifics, but im pretty sure its 4x AA and not sure about anything else :S
m
0
l
May 26, 2011 11:52:13 PM

Anti Aliasing is probably whats killing the FPS. I suggest turning it off
m
0
l
May 27, 2011 12:04:28 AM

Is the 5770 similar in performance to a gts 450?

I use the gts 450 which is the same price as the 5770 and play sc2 with every setting set at the highest and maintain around 60 fps.

I would expect similar from your card, correct me if I'm wrong though please.
m
0
l
a b U Graphics card
May 27, 2011 12:15:35 AM

Gobble45 said:
Hey guys, my rig is;
AMD Phenom II X4 955 3.2ghz
asrock 880g Mobo
XFX HD 5770 Graphics
Corsair 4x2gb 1333 DDR3
Win7 64bit
my graphics drivers updated 2 days ago.

im running starcraft 1920x1080 medium settings, and still getting major lag.
my internet connection is fine, its a graphic/system lag :S



did you have the lag before the driver update? if so roll back your driver...and is it only laggy when you play online? I had this game running with my old hd 4650 oc on mostly high settings and it ran fine....I have the 5770 now and its a great card no lag on any game I have tried now. do you overclock you gfx card? do you use ccc?
m
0
l
a b U Graphics card
May 27, 2011 12:27:40 AM

KingKenny said:
Is the 5770 similar in performance to a gts 450?

I use the gts 450 which is the same price as the 5770 and play sc2 with every setting set at the highest and maintain around 60 fps.

I would expect similar from your card, correct me if I'm wrong though please.





Actually the 5770 beats out the 450 when clocked right but it also depnds on what chipset is in your board as well for example an amd chipset will run their ati cards better cuz thats what they build them to "communicate" with each other. where as I had Some cash dumped in my hands so I got the new 580 which did not impress me at all where as it should have...but I found out It was because of my chipset that the the mobo cpu and gfx did not play nicley with each other.. I score 19500 with 3d06 with my card clocked to 1050/1490 stock voltage as i dont have the option of uping my voltage on this card where as with the 580 I picked up I oc'd everything and got a rough 21000 out of 3do6. Hands down that the 580 is far better card its all how your system runs and "communicates" with the rest of your hardware
m
0
l
a b U Graphics card
May 27, 2011 12:41:40 AM

HAHA basically what I said without the fancy graphs :ouch:  ....show off. good info...not knockin you in any way Where did you find that graph? again good job with the info greghome.
m
0
l
May 27, 2011 1:04:00 AM

well, i noticed the lag on tuesday, and a friend suggested updating drivers, so i did, and well, didnt help the matters, but its only SC2, i play crysis 2 on the 2nd best settings, with a steady 35-45 frames.
m
0
l
a b U Graphics card
May 27, 2011 6:00:22 AM

is it when your playing online? or still single player? what are you using for overclocking?
m
0
l
May 27, 2011 6:39:43 AM

AA isnt off atm, its at 4x currently.. and yes its when i play online, i have tried single player since the lag set in.. but my connection is never bad.
m
0
l
a b U Graphics card
May 27, 2011 6:49:13 AM

do you have your system overclocked? You might just have to wait for a patch if this is a reoccurring lagging issue online. I know when I got brink I played online everything was nice and smooth but the more the servers loaded up the laggier it got and steam just released a patch for that issue and its still choppy. but when i put my rig back to default settings my online gaming got a little smoother
m
0
l
May 27, 2011 6:54:08 AM

no my system isnt overclocked. i used the CCC AMD Overdrive thingy on for my graphics, should i try reseting to default?
m
0
l
a b U Graphics card
May 27, 2011 7:15:58 AM

no get rid of ccc download trixx sapphire tweak utility and over clock your graphics with that...ccc restricts your cards performance to its max potential your cpu is it the black edition?
m
0
l
May 27, 2011 9:22:06 AM

starcraft doesnt have an AA option. lol.. im trying a starcraft repair
m
0
l
May 27, 2011 9:24:20 AM

and no its not the black edition
m
0
l
a b U Graphics card
May 27, 2011 4:13:40 PM

did you get rid of ccc?
m
0
l
May 28, 2011 12:44:25 AM

i didnt get rid of it, but i just set my graphics card back to default clock settings, and now i can play SC2 at ultra settings, with minimal lag :D  cheers for the help guys
m
0
l
May 28, 2011 12:45:47 AM

Best answer selected by Gobble45.
m
0
l
a b U Graphics card
May 28, 2011 12:47:41 AM

Well, that meant that your card was unstable. Good luck and pwn some guys for me.
m
0
l
!