Sign in with
Sign up | Sign in
Your question

Toubleshooting: USB keyboards not working

Tags:
Last response: in Systems
Share
August 2, 2011 11:44:01 AM

Long time reader, first time poster. Came across an odd situation this weekend after upgrading son's computer to Win7 Home Premium 64bit.

First, I have built several computers, this is the first I've ever had an issue. The problem started with a PC built last year, the video card was losing state during switching users. (Vista Home Premium 32, AMD Athlon x2 3.0ghz, 3gb gddr3, with Nvidia GeForce 8600GT) I had read about several similar issues with this pairing so I decided to upgrade the OS first, after all it is Vista. Purchased Win7 Home Premium OEM at CompUSA, performed a fresh install, no issues during install. On reboot at post I noticed I did not have keyboard support, mouse was fine. Figured this may be a driver issue and used the onscreen keyboard to complete the install process. After entering windows i went ahead and installed drivers for the connected components and then rebooted. Again, no keyboard support at post. Decided to run the windows repair, frustratingly, this did not help either. On a whim loaded several popular keyboard drivers (MS intellipoint, Logitech, etc) still no keyboard support.

At this point I began swapping my devices around the Available USB ports (4 USB2 in rear, 2 USB3 in Rear, 2 USB2 in front); mouse works fine in all ports, Belking n Adapter works fine in all ports, HP 8gb thumb works fine in all ports, WD 320gb External, working in all ports. Several keyboards (all usb), will not work in any port. At this point I decided to disconnect the Video card & Rocketfish sound card from the board under the assumption that I was having a bus issue. No progress. Removed ram, optical drive, no progress (repeat 2x for each stick). Found a PS2 keyboard, plugged in, rebooted, WORKS! Check bios, USB devices enabled at boot, legacy USB support active. Go to windows, uninstall all USB devices & drivers, reboot, hardware manager reinstalled. Check USB keyboard connectivity - not detected. Plug in mouse - detected. Plug in wireless adapter - detected....

New Assumption - bad mobo. Trip to Compusa. No AM2 boards in stock. Purchase:
Biostar TA8 series AM3 series mobo
AMD x4 Phenom II 955 Black Edition
8gb GDDR3 Kingston hyperX
Zotac GTX 550 TI

Build - Reboot........ No USB keyboard support
(2 hours of swearing)
Pull HDD - use Acronis to scrub clean. Reinstall Win7.... No USB Keyboard support. Repeat the above steps with all the new equipment, no avail.

Current status: machine kicks butt, however no USB keyboards will work with it.....

Any thoughts, help, advice greatly appreciated
August 2, 2011 11:52:37 AM

I forget to mention, I did make sure, in both MOBO's that the bios were up to date, and reset them each to make sure
August 5, 2011 2:58:15 PM

Issue resolved -

The original MOBO has a short in the USB that was frying the hardware I connected to it. I had tested each keyboard, then after the rebuild was working under the assumption that the keyboard was still functional.

Determined this after I attempted to use a USB flash drive on the old board then tried to use the same drive on my laptop. Confirmed by burning out 2 more USB flash drives.
!