Sign in with
Sign up | Sign in
Your question

Windows 7 64bit can't see optical drives

Last response: in Systems
Share
August 3, 2011 1:44:40 AM

Hi,
I just built my first computer. I'm using an ASUS Rampage III Extreme motherboard with an Intel I7 990x cpu. The mobo has an ICH10R controller that I'm running a four drive RAID10 on.
Here's the problem. I originally had my two optical drives plugged into the ICH10R sockets also. But when I log on and select Start+Computer, all that listed out was the RAID. No DVD drive, no blue-ray burner. So, I go into Device Manager. It can see the optical drives but returns the following error message for both
"Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)"
Thinking the problem might be that I've got the two optical drives on the same controller as a RAID, I switched the two optical drive cables to the two Marvell 88SE9128 controller sockets. Installed the Marvell drivers. Same problem. Same message in Device Manager.
I tried hitting CNTRL+M during boot-up to bring up the Marvell controller panel. It sees both drives fine.
I know that the DVD drive works fine since I used it to install Windows 7. It seems as though after I installed the RAID driver during the Win 7 install, windows ceased being able to see either optical drive.
Everything else in the system seems to be working fine.
I don't know what to make of all this...
Any suggestions?
Thanks!
Gordon
August 3, 2011 2:41:04 AM

The reason I'm not sure is that this page recomends a solution for similar problems, but not for the Code 52 error.
August 4, 2011 2:42:59 AM

Okay. For the record. The above fix does work for the Code 52 error in Device Manager. You delete the one registry entry (upper and lower filters) and the problem is solved. Thanks all for considering my problem.
Gordon
!