32 gb of memory not reading in bios

I am having trouble reading my memory in bios or windows 7 pro 64. But I can view it in cpu-z. Does anyone know why...
15 answers Last reply
More about memory reading bios
  1. what mobo do you own.
  2. Asus P8z77-v lx
    I5 2500k 3.3
    32 corsair memory
    7850 radeon hd x2
    ssd drive 250gb
  3. I purchased the new 32gb memory that is all one set, and still no luck with seeing it in bios, or windows. But the CPU-z will have no problems seeing it at all.


    I am truly lost, I spend 100.00 to have a tech look at it and came the astounding solution that the memory was the problem, but no its not. Cause even the other unpaired memory still was seen in the cpu-z
  4. which model ram did you buy in particular.
  5. cmz32gx3m41600c10
  6. according to asus, the memory sticks checks out assuming its model cmz32gx3m4x1600c10

    its odd that the computer itself is not sensing the ram. have you tried sensing it in groups of 16 gb( 2 sticks only) and seeing if the computer will boot in different groups of two?
  7. Yes, and I have tried just one stick and two sticks in different config, and all works. Except the max it will read is 16gb
  8. assuming that it is win7 professional like the op says, Microsoft says it should have an upper limit of 192 gb of ram

    you would only have a limit of 16 if its home premium or lower
  9. I am in the process of RMA'ing the board back. I can not think of anything else can you.
  10. call asus and ask them to help you, before just returning, unless you are on a time crunch.
    You may get the 2nd board and just have the same issue.


    You have updated the bios?
  11. I have updated the bios
  12. I get your point on another board. I just have heard nothing from my emails to them at all.
  13. After waiting for asus for about an hour there tech support had no idea other than it must be a faulty mobo.

    Thanks for all the help, hope i do not need it again later once the new one arrives tomorrow.
  14. Run msconfig, then navigate to the boot tab and click advanced options there will be a maximum memory box it should be unchecked

    Sometimes this works to get the ram picked up right.
  15. Already unchecked, but thank you
Ask a new question

Read More

Memory BIOS Windows 7