Sign in with
Sign up | Sign in
Your question

XFX ATI 5850 Black Edition Blue Screen

Last response: in Graphics & Displays
Share
June 1, 2011 3:02:00 PM

Hi, I have recently built a new pc, which was around 4 weeks ago. The only thing left to upgrade was the graphics card which I did not do at that time. Today I received the graphics card which i upgraded from an 8800gts to an XFX ATi Radeon HD 5850 1GB.

My problem with the XFX 5850 Black Edition is that it randomly crashes and I end up getting the BSOD (Blue Screen Of Death), I tried this card with games such as COD Black Ops and L4D2 which run fine, but when i try Crysis Warhead, it flickers and shortly after it all I get the BSOD. Its not only on games this occurs, even when im using the internet, it also does it when the pc is idling.

The specs of my system are:

Intel core i5 2500k, Asus P8P67 Motherboard, XFX ATI 5850 Black Edition, 4GB (2x2gb) Kingston Hyper-x DDR3 1600, 650W Cooler Master PSU and a Seagate 500GB hard drive.

I have uninstalled all drivers off the system of the previous graphics card and installed the new 5850 correctly. I have tried using the latest drivers from the AMD website, and I have even rolled back to the drivers off the disc which are older, but after finding that the problem is still persisting I have installed the latest driver again and I am still having the BSOD problem happening every now and again.

If someone could please help me tackle this problem as I would like to know if the drivers are at fault or if the Graphics card itself is the problem.
June 3, 2011 1:28:44 AM

As I am still having this problem with the XFX 5850 gpu on my windows 7 64 bit system after trying Driver sweeper after uninstalling and reinstalling the lastest ATi driver, I seem to be at a loss. I have read up and discovered that Im not the only one having this problem when during a game I get flickering lines appearing on the screen and it then crashing with the BSOD. When i exit the games after the flickering lines I get the message "Display driver has stopped working and has been succsessfully recovered."

I have tried 2 different Nvidia cards which I do not have this problem with, so it rules out the fact that my other hardware components could be at fault, which they should'nt as they are new. The card is not having any temperature problems and it is seated properly in the expansion slot.

I have not overclocked this card or underclocked it in any way, neither am I crossfiring it with multiple displays.

I really need help to solve this problem, as it is very frustrating and annoying as I did not expect anything like this from a graphics card like this, and I have tried as many things as i can to solve this problem, but it still occurs when I play a game like Crysis Warhead, and even the other games which are L4D2, Call of Duty Black Ops and Lost Planet 2 where I thought the problem didnt happen on, which is where I was mistaken.


Need help with this urgently Please!!
!