Asus Sabertooth 990FX Memory issues.

I recently upgraded my memory to 8GB ddr3 1866 (9-9-9-24), currently installed into slots 1 & 3, but for some reason I can only get them to run at 1600, my motherboard is listed to be compatible with 1866 and when I run cpu-z the memory has 1866 in the name and it recognises that I have 8GB off memory, so it's the right memory. On the box for the memory it says it's compatible with Phenom. I've read a few other forums and they say you have to manually change the settings, but I'm new to this and not sure what settings to change and what to change them to.

My current pc specs are
Asus Sabertooth 990FX Motherboard (v0901 bios)
Sapphire 6850 gpu
Phenomenon x6 ii 1090t
8GB of corsair Vengeance ddr3 1866 (9-9-9-24)

Any help would be appreciated.
2 answers Last reply
More about asus sabertooth 990fx memory issues
  1. Edit the memory timings are 9-10-9-27 NOT 9-9-9-24
  2. Sort of fixed it, my memory is currently set to 1864, looks pretty stable, haven't had a bsod yet.
Ask a new question

Read More

Memory Sabertooth Compatibility