Sign in with
Sign up | Sign in
Your question
Solved

CCC 11.5 issues with playing games full screen on HDMI external ! HELP

Last response: in Graphics & Displays
Share
June 2, 2011 7:04:39 PM

Having a problem. I have a Asus G73JH laptop, with ATI Mobility Radeon 5870. I updated my bios to the latest version so I could install the latest ATI drivers without getting GSOD freezes (knows issue with these laptops, and updating bios fixed that issue). Anyhow, I am finally ably to use the latest ATI drivers and CCC 11.5 without getting freezing/GSOD ... but here is the issue now...

After installing CCC 11.5 my desktop resolution was set properly (1920x1080p) and using my HDMI out to my LCD display, however the screen wasnt fitting my whole monitor... found out I had to go into CCC and adjust my scaling options... I did that, and it fixed my issue on my Windows 7 desktop, it fills up my full external monitor screen (no black bars around it anymore)... but the issue is when i run video games, the scaling seems to "reset" itself and i am stuck playing games not in full screen... its very frustrating... i tried to ALT TAB and get to my desktop while game is running, by when i switch from the game to the desktop, my monitor flashes and the scaling goes back to its correct way for the desktop, so it doesnt alolow me to adjust the scaling in games... when I alt tab back to my game, screen flickers and goes back to game not filling full screen. I hope I am explaining this correctly. I have seen people have similar issues but never could find a solution directly related to CCC 11.5


Please help! thanks!!!
June 2, 2011 7:46:01 PM

I've seen that behavior in my own computer when re-plugging the monitor through the HDMI... Can't explain why, but after plugging it, I need to restart for the games to scale well again.

So, for a second monitor i guess it should be like: turn on notebook -> plug hdmi -> set overcan -> restart without unplugging hdmi -> game

Try that and see how it goes, hope it fixes the issue.

Cheers!

EDIT: My notebook has an nVidia GT425M, which has the same problem and rebooting fixes it (sometimes).
m
0
l
June 2, 2011 8:00:58 PM

yeah tried that, no go... my laptop is always plugged into my external via hdmi cable, its been plugged in for the last 6 months straight. its really a weird issue... it looks like i am only able to control my scaling on my desktop, but when a game launches it seems to ignore the destop resolution & its scaling and causes the games to play and take up the whole screen of my monitor. I was able to get 1 game to work actually... Cities XL 2011, when the game was loaded, it showed up not filling the while screen, so i hit alt tab and mashed a bunch of button which caused me to go to my desktop, however it was showing my desktop in the resolution the game is in that isnt taking up the full screen of my monitor... so i went into CCC and adjusted the scaling and saved, and ALT TAB back to my game, and it actually fixed the scaling for this game... its filling the complete size of my external LCD.... but unfortuantly I jimmied the fix for just this game... problem is i Cannot seem to get it to work for any other game..... ugh this sux. its gotta be a setting somewhere I am missing that should fix this...
m
0
l
Related resources
June 2, 2011 8:03:54 PM

i saw some people say using a DVI out cable rather then HDMI works, but my laptop only had HDMI out and VGA out.....

i guess I could try connecting via a VGA cable... but wouldnt the picture look crappy compared to using HDMI?
m
0
l

Best solution

June 2, 2011 8:29:24 PM

SOLVED!!!!!!!

OK here is what I did to fix my problem... in CCC i when into desktop properties and I adjusted each refresh rate for all my 1080p res profile... so i selected 60hz, apply, adjusted scaling (+0) .... and repeated these steps for each refresh rate (60...50...30...25, etc)... as I was going into each refresh rate mode, it was resetting my screen to not fit the whole size of my external monitor... so i was able to go into my scaling options in CCC and overscale for every refresh rate that was not filling up my whole screen on my external display (connected via HDMI)....

after I did this, every game I play now displays its picture in the full size of my external monitor... bingo!
Share
June 2, 2011 8:43:52 PM

What is your external monitor's resolution? 1080p also?

If that's so, I don't know if you'll be able to get 1080p out of the VGA connector (standards). Also, you could try 1 more thing: instead of using 1920x1080, use 1680x1050 as native resolution and don't use the "hdmi" native resolution.

There's also another option that could work: set the external monitor as the primary display and turn off the notebook screen by selecting "single display".

Cheers!

EDIT: hahaha, nice. Great going!
m
0
l
June 2, 2011 8:52:09 PM

thanks, took me most of the day of fiddling... but i am glad I got it fixed. i noticed alot of people have this issue, hope they come across this thread
m
0
l
June 2, 2011 9:34:16 PM

People hardly looks up information before posting (myself, sadly, included), so it's good enough for you and me to know how to fix that issue now (or at least have one more shot at it xD).

I'm sure more folks will come and read your issue and solution and the knowledge will prevail 8)

Cheers!
m
0
l
June 19, 2013 2:41:18 AM

bsdesign said:
SOLVED!!!!!!!

OK here is what I did to fix my problem... in CCC i when into desktop properties and I adjusted each refresh rate for all my 1080p res profile... so i selected 60hz, apply, adjusted scaling (+0) .... and repeated these steps for each refresh rate (60...50...30...25, etc)... as I was going into each refresh rate mode, it was resetting my screen to not fit the whole size of my external monitor... so i was able to go into my scaling options in CCC and overscale for every refresh rate that was not filling up my whole screen on my external display (connected via HDMI)....

after I did this, every game I play now displays its picture in the full size of my external monitor... bingo!


You also have to do this for every 16:9 resolution you plan on gaming. I had to use overscan for 720p also, as one of my game was set at 720p. I haven't tried it for other 16:9 resolution though but had to use overscan for a 1000p(yes 1000, not 1080p. what a strange resolution) so guess whatever resolution you set your game to, you have to use overscan for those resolutions(for all frequencies)
m
0
l
!